summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-08-04 11:02:30 -0600
committerMark Wagie2022-08-04 11:02:30 -0600
commitd733b9fbbb7769395373f97c954accd3f23c78af (patch)
tree25cd399a90c2aa329ed24df66dbcc2c54d9aff93
parentb26fa1056d79a0fae338e1131b261eaeb3eb4e25 (diff)
downloadaur-d733b9fbbb7769395373f97c954accd3f23c78af.tar.gz
use Electron 20
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--clipto2
3 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee8ae48c1cc7..4c12ad8610bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = clipto-bin
pkgdesc = Effortless, super fast and flexible notes taking app and clipboard manager.
pkgver = 7.2.17
- pkgrel = 7
+ pkgrel = 8
url = https://clipto.pro
arch = x86_64
license = custom
- depends = electron
+ depends = electron20
optdepends = libnotify: for desktop notifications
optdepends = libappindicator-gtk3: for tray icon
provides = clipto
@@ -15,6 +15,6 @@ pkgbase = clipto-bin
source = https://github.com/clipto-pro/Desktop/releases/download/v7.2.17/clipto-7.2.17.AppImage
source = clipto
sha256sums = ed0fc3b0e84efc986fdb41a1a38a1483c61d3c128eaa5014e97dc14c3b376028
- sha256sums = 9a741f1a1760de706698cb1576e3bb08846876c359aedd5d8854e69d913f0635
+ sha256sums = 4668c84dc0fae7324f905da6fb894fbb7674eeec673836c506994298732c8904
pkgname = clipto-bin
diff --git a/PKGBUILD b/PKGBUILD
index 406356f47c60..a5d5e4aa36db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=clipto-bin
pkgver=7.2.17
-pkgrel=7
+pkgrel=8
+_electronversion=20
pkgdesc="Effortless, super fast and flexible notes taking app and clipboard manager."
arch=('x86_64')
url="https://clipto.pro"
license=('custom')
-depends=('electron')
+depends=("electron${_electronversion}")
optdepends=('libnotify: for desktop notifications'
'libappindicator-gtk3: for tray icon')
provides=("${pkgname%-bin}")
@@ -15,7 +16,7 @@ replaces=("${pkgname%-bin}.pro")
source=("https://github.com/clipto-pro/Desktop/releases/download/v$pkgver/${pkgname%-bin}-$pkgver.AppImage"
"${pkgname%-bin}")
sha256sums=('ed0fc3b0e84efc986fdb41a1a38a1483c61d3c128eaa5014e97dc14c3b376028'
- '9a741f1a1760de706698cb1576e3bb08846876c359aedd5d8854e69d913f0635')
+ '4668c84dc0fae7324f905da6fb894fbb7674eeec673836c506994298732c8904')
prepare() {
chmod +x "${pkgname%-bin}-$pkgver.AppImage"
diff --git a/clipto b/clipto
index 51e3b9500f2c..0e69d429c5e6 100644
--- a/clipto
+++ b/clipto
@@ -1,3 +1,3 @@
#!/bin/bash
-exec electron /usr/lib/clipto/resources/app.asar "$@"
+exec electron20 /usr/lib/clipto/resources/app.asar "$@"