summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-01-25 11:53:02 -0700
committerMark Wagie2022-01-25 11:53:02 -0700
commitd78f42bb3ecafd330020b55f1c62fb804e031853 (patch)
treedf6d46683c99d4ccf402015960d4046642dab1dd
parentb3a7b203623e4f62a86a1407ccd3a5581a2e435f (diff)
downloadaur-d78f42bb3ecafd330020b55f1c62fb804e031853.tar.gz
use electron15
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--clipto2
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e65509e517d..93e6e6619baa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = clipto-bin
pkgdesc = Effortless, super fast and flexible notes taking app and clipboard manager.
pkgver = 7.2.17
- pkgrel = 3
+ pkgrel = 4
url = https://clipto.pro
arch = x86_64
license = custom
- depends = electron
+ depends = electron15
optdepends = libnotify: for desktop notifications
optdepends = libappindicator-gtk3: for tray icon
provides = clipto
@@ -15,6 +15,6 @@ pkgbase = clipto-bin
source = https://github.com/clipto-pro/Desktop/releases/download/v7.2.17/clipto-7.2.17.AppImage
source = clipto
sha256sums = ed0fc3b0e84efc986fdb41a1a38a1483c61d3c128eaa5014e97dc14c3b376028
- sha256sums = 9a741f1a1760de706698cb1576e3bb08846876c359aedd5d8854e69d913f0635
+ sha256sums = 53a200544b66a91f2d3129682c2f78f1a146b5256617c1f25c485ff74e7d42c6
pkgname = clipto-bin
diff --git a/PKGBUILD b/PKGBUILD
index dbab7412c674..b4d52cd50c68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=clipto-bin
pkgver=7.2.17
-pkgrel=3
+pkgrel=4
pkgdesc="Effortless, super fast and flexible notes taking app and clipboard manager."
arch=('x86_64')
url="https://clipto.pro"
license=('custom')
-depends=('electron')
+depends=('electron15')
optdepends=('libnotify: for desktop notifications'
'libappindicator-gtk3: for tray icon')
provides=("${pkgname%-bin}")
@@ -15,7 +15,7 @@ replaces=("${pkgname%-bin}.pro")
source=("https://github.com/clipto-pro/Desktop/releases/download/v$pkgver/${pkgname%-bin}-$pkgver.AppImage"
"${pkgname%-bin}")
sha256sums=('ed0fc3b0e84efc986fdb41a1a38a1483c61d3c128eaa5014e97dc14c3b376028'
- '9a741f1a1760de706698cb1576e3bb08846876c359aedd5d8854e69d913f0635')
+ '53a200544b66a91f2d3129682c2f78f1a146b5256617c1f25c485ff74e7d42c6')
prepare() {
chmod +x "${pkgname%-bin}-$pkgver.AppImage"
diff --git a/clipto b/clipto
index 51e3b9500f2c..45f756ab2e0a 100644
--- a/clipto
+++ b/clipto
@@ -1,3 +1,3 @@
#!/bin/bash
-exec electron /usr/lib/clipto/resources/app.asar "$@"
+exec electron15 /usr/lib/clipto/resources/app.asar "$@"