summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2017-06-27 21:31:56 +0200
committerÉtienne Deparis2017-06-27 21:31:56 +0200
commit0121da6fc330f9408b6f02c16f5ac45288f1747e (patch)
tree738566599862b3610e915f45d14bc33bea551c65
parent9a574bd2a3d8badc61af0c0405e644a579b46d1c (diff)
downloadaur-0121da6fc330f9408b6f02c16f5ac45288f1747e.tar.gz
New release 1.14.0
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD49
2 files changed, 42 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 501a600832a0..bc0269b47ca0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,45 +1,48 @@
# Generated by makepkg 5.0.2
-# Fri Jun 16 22:26:47 UTC 2017
+# Tue Jun 27 19:31:30 UTC 2017
pkgbase = cliqz
pkgdesc = Firefox-based privacy aware web browser
- pkgver = 1.13.6
+ pkgver = 1.14.0
pkgrel = 1
url = https://cliqz.com/
arch = i686
arch = x86_64
license = MPL2
- makedepends = python2
+ makedepends = unzip
makedepends = zip
- makedepends = autoconf2.13
+ makedepends = diffutils
+ makedepends = python2
makedepends = yasm
- makedepends = libidl2
- makedepends = linux-api-headers
- makedepends = rust
+ makedepends = mesa
+ makedepends = gconf
+ makedepends = inetutils
+ makedepends = xorg-server-xvfb
+ makedepends = autoconf2.13
makedepends = cargo
makedepends = gcc5
- depends = alsa-lib
- depends = dbus-glib
- depends = ffmpeg
- depends = gtk2
depends = gtk3
- depends = hunspell
- depends = icu
- depends = libevent
- depends = libvpx
+ depends = gtk2
+ depends = mozilla-common
depends = libxt
+ depends = startup-notification
depends = mime-types
- depends = mozilla-common
+ depends = dbus-glib
+ depends = alsa-lib
+ depends = ffmpeg
depends = nss
+ depends = hunspell
depends = sqlite
- depends = startup-notification
depends = ttf-font
+ depends = libpulse
+ depends = icu
+ depends = libvpx
conflicts = cliqz-bin
options = !emptydirs
options = !makeflags
options = !strip
- source = https://github.com/cliqz-oss/browser-f/archive/1.13.6.tar.gz
+ source = https://github.com/cliqz-oss/browser-f/archive/1.14.0.tar.gz
source = fix-wifi-scanner.diff
- sha256sums = 00889950244c53baeaf6617ed26de3d2bee1a960aaaa0eb74b1fc9e554d49658
+ sha256sums = 1e76675e06cea21379c454a862754c4133f293aac08eca30e0dbd4fc993132a1
sha256sums = 9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8
pkgname = cliqz
diff --git a/PKGBUILD b/PKGBUILD
index 69efd60d3ced..610406f3a595 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,30 @@
# Maintainer: Étienne Deparis <etienne@depar.is>
pkgname=cliqz
_pkgname=browser-f
-_vendorname=CLIQZ
-pkgver=1.13.6
+pkgver=1.14.0
pkgrel=1
+_cqzbuildid=20170625170852
pkgdesc="Firefox-based privacy aware web browser"
-arch=('i686' 'x86_64')
+arch=(i686 x86_64)
url="https://cliqz.com/"
-license=('MPL2')
-depends=('alsa-lib' 'dbus-glib' 'ffmpeg' 'gtk2' 'gtk3' 'hunspell'
- 'icu' 'libevent' 'libvpx' 'libxt' 'mime-types'
- 'mozilla-common' 'nss' 'sqlite' 'startup-notification'
- 'ttf-font')
-makedepends=('python2' 'zip' 'autoconf2.13' 'yasm' 'libidl2'
- 'linux-api-headers' 'rust' 'cargo' 'gcc5')
-conflicts=('cliqz-bin')
+license=(MPL2)
+depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib ffmpeg
+ nss hunspell sqlite ttf-font libpulse icu libvpx)
+makedepends=(unzip zip diffutils python2 yasm mesa gconf inetutils xorg-server-xvfb
+ autoconf2.13 cargo gcc5)
+conflicts=(cliqz-bin)
source=("https://github.com/cliqz-oss/browser-f/archive/${pkgver}.tar.gz"
"fix-wifi-scanner.diff")
-sha256sums=('00889950244c53baeaf6617ed26de3d2bee1a960aaaa0eb74b1fc9e554d49658'
+sha256sums=('1e76675e06cea21379c454a862754c4133f293aac08eca30e0dbd4fc993132a1'
'9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8')
options=(!emptydirs !makeflags !strip)
prepare() {
cd $srcdir/$_pkgname-$pkgver/mozilla-release
sed -i 's/ifeq ($(OS_ARCH), Linux)/ifeq ($(OS_ARCH), Nope)/' toolkit/mozapps/installer/upload-files.mk
- sed -i "s/@MOZ_APP_DISPLAYNAME@/$_vendorname/g" toolkit/mozapps/installer/linux/rpm/mozilla.desktop
+ sed -i "s/@MOZ_APP_DISPLAYNAME@/$pkgname/g" toolkit/mozapps/installer/linux/rpm/mozilla.desktop
sed -i "s/@MOZ_APP_NAME@/$pkgname/g" toolkit/mozapps/installer/linux/rpm/mozilla.desktop
- # We get a 403 on this one
- sed -i 's|CLIQZ_EXT_URL = "http://cdn2.cliqz.com/update/browser/Cliqz.1.13.0.xpi"|CLIQZ_EXT_URL = "http://repository.cliqz.com.s3.amazonaws.com/dist/release/1.13.6/20170522183742/cliqz%40cliqz.com.xpi"|' config/rules.mk
-
# https://bugzilla.mozilla.org/show_bug.cgi?id=1314968
patch -Np1 -i $srcdir/fix-wifi-scanner.diff
@@ -37,20 +32,19 @@ prepare() {
# Note: These are for Arch Linux use ONLY. For your own distribution, please
# get your own set of keys. Feel free to contact foutrelis@archlinux.org for
# more information.
- echo -n "AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM" > google-api-key
- sed -i "s|/builds/google-desktop-api.key|${PWD@Q}/google-api-key|" browser/config/cliqz-release.mozconfig
+ echo -n "AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM" > browser/google-desktop-api.key
# Mozilla API keys (see https://location.services.mozilla.com/api)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
# get your own set of keys. Feel free to contact heftig@archlinux.org for
# more information.
- echo -n "16674381-f021-49de-8622-3021c5942aff" > mozilla-api-key
- sed -i "s|/builds/mozilla-desktop-geoloc-api.key|${PWD@Q}/mozilla-api-key|" browser/config/cliqz-release.mozconfig
+ echo -n "16674381-f021-49de-8622-3021c5942aff" > browser/mozilla-desktop-geoloc-api.key
cat >.mozconfig <<END
ac_add_options --prefix=/usr
ac_add_options --enable-gold
ac_add_options --enable-pie
+ac_add_options --enable-optimize="-O2"
# System libraries
ac_add_options --with-system-nspr
@@ -59,7 +53,6 @@ ac_add_options --with-system-icu
ac_add_options --with-system-jpeg
ac_add_options --with-system-zlib
ac_add_options --with-system-bz2
-ac_add_options --with-system-libevent
ac_add_options --with-system-libvpx
ac_add_options --enable-system-hunspell
ac_add_options --enable-system-sqlite
@@ -68,7 +61,6 @@ ac_add_options --enable-system-pixman
# Features
ac_add_options --enable-startup-notification
-ac_add_options --enable-alsa
ac_add_options --disable-updater
STRIP_FLAGS="--strip-debug"
@@ -82,9 +74,6 @@ build() {
march=$(gcc -Q --help=target | grep march | sed -nr 's/^.*\s+([^\s]+)$/\1/p')
CFLAGS="-march=${march} -mtune=generic -O2 -fstack-protector-strong"
- # No need for this one, already in CFLAGS
- # CPPFLAGS+=" -O2"
-
# Hardening is currently deactivated as it hangs on my current machine
# Hardening
LDFLAGS+=" -Wl,-z,now"
@@ -94,6 +83,8 @@ build() {
export CC=/usr/bin/gcc-5
export CQZ_RELEASE_CHANNEL=release
+ export CQZ_VERSION=$pkgver
+ export CQZ_BUILD_ID=$_cqzbuildid
./magic_build_and_package.sh
}
@@ -103,11 +94,11 @@ package() {
install -d -m755 ${pkgdir}/usr/{bin,lib}
- ln -s /usr/lib/${_vendorname}/${_vendorname} ${pkgdir}/usr/bin/${pkgname}
+ ln -s /usr/lib/${pkgname}/${pkgname} ${pkgdir}/usr/bin/${pkgname}
- mv $_pkgname-$pkgver/obj/dist/$_vendorname-$pkgver.en-US.linux-x86_64.tar.bz2 .
- tar xjf $_vendorname-$pkgver.en-US.linux-x86_64.tar.bz2
- cp -R $_vendorname ${pkgdir}/usr/lib/
+ mv $_pkgname-$pkgver/obj/dist/${pkgname}-${pkgver}.en-US.linux-x86_64.tar.bz2 .
+ tar xjf ${pkgname}-${pkgver}.en-US.linux-x86_64.tar.bz2
+ cp -R $pkgname ${pkgdir}/usr/lib/
for size in 16 22 24 32 48 256; do
install -D -m644 $_pkgname-$pkgver/mozilla-release/browser/branding/cliqz/default$size.png \