summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2017-03-31 11:21:46 +0200
committerÉtienne Deparis2017-03-31 11:21:46 +0200
commit2118ed655c2f8dd5e5634b4aeb48c798863447f6 (patch)
tree07bcee99ae40e2960c2946bf1be3a5d0d73e9d22
parentd6439ebb7e21412f770bd7118f352eb5921ef350 (diff)
downloadaur-2118ed655c2f8dd5e5634b4aeb48c798863447f6.tar.gz
Begin to work on 1.12 version
-rw-r--r--PKGBUILD30
-rw-r--r--fix-wifi-scanner.diff16
-rw-r--r--rust-i686.patch16
3 files changed, 59 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6f3c97ca758f..d6ecaa1ea189 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=cliqz
_pkgname=browser-f
_vendorname=CLIQZ
-pkgver=1.11.1
+pkgver=1.12.0
pkgrel=1
pkgdesc="Firefox-based privacy aware web browser"
arch=('i686' 'x86_64')
@@ -14,8 +14,12 @@ depends=('alsa-lib' 'dbus-glib' 'ffmpeg' 'gtk2' 'gtk3' 'hunspell'
'ttf-font')
makedepends=('python2' 'zip' 'autoconf2.13' 'yasm' 'libidl2' 'linux-api-headers')
conflicts=('cliqz-bin')
-source=("https://github.com/cliqz-oss/browser-f/archive/${pkgver}.tar.gz")
-sha256sums=('653df00962403baada8632cd07a129601d43b77dbc0ca025521fd84a567c9681')
+source=("https://github.com/cliqz-oss/browser-f/archive/${pkgver}.tar.gz"
+ "rust-i686.patch"
+ "fix-wifi-scanner.diff")
+sha256sums=('cf4fcfa04a79426033c1553d2c3a85a40031a02e28f1b695613af6d050b874cf'
+ 'f61ea706ce6905f568b9bdafd1b044b58f20737426f0aa5019ddb9b64031a269'
+ '9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8')
options=(!emptydirs !makeflags !strip)
prepare() {
@@ -24,6 +28,26 @@ prepare() {
sed -i "s/@MOZ_APP_DISPLAYNAME@/$_vendorname/g" toolkit/mozapps/installer/linux/rpm/mozilla.desktop
sed -i "s/@MOZ_APP_NAME@/$pkgname/g" toolkit/mozapps/installer/linux/rpm/mozilla.desktop
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1314968
+ patch -Np1 -i $srcdir/fix-wifi-scanner.diff
+
+ # Build with the rust targets we actually ship
+ patch -Np1 -i $srcdir/rust-i686.patch
+
+ # Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
+ # Note: These are for Arch Linux use ONLY. For your own distribution, please
+ # get your own set of keys. Feel free to contact foutrelis@archlinux.org for
+ # more information.
+ echo -n "" > google-api-key
+ sed -i "s|/builds/google-desktop-api.key|${PWD@Q}/google-api-key|" browser/config/cliqz-release.mozconfig
+
+ # Mozilla API keys (see https://location.services.mozilla.com/api)
+ # Note: These are for Arch Linux use ONLY. For your own distribution, please
+ # get your own set of keys. Feel free to contact heftig@archlinux.org for
+ # more information.
+ echo -n "" > mozilla-api-key
+ sed -i "s|/builds/mozilla-desktop-geoloc-api.key|${PWD@Q}/mozilla-api-key|" browser/config/cliqz-release.mozconfig
+
cat >.mozconfig <<END
ac_add_options --prefix=/usr
ac_add_options --enable-gold
diff --git a/fix-wifi-scanner.diff b/fix-wifi-scanner.diff
new file mode 100644
index 000000000000..f8fdd6c42142
--- /dev/null
+++ b/fix-wifi-scanner.diff
@@ -0,0 +1,16 @@
+ netwerk/wifi/nsWifiScannerDBus.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git c/netwerk/wifi/nsWifiScannerDBus.cpp i/netwerk/wifi/nsWifiScannerDBus.cpp
+index 182553e18fa6e104..6fa0a0b023d3e45f 100644
+--- c/netwerk/wifi/nsWifiScannerDBus.cpp
++++ i/netwerk/wifi/nsWifiScannerDBus.cpp
+@@ -62,7 +62,7 @@ nsWifiScannerDBus::SendMessage(const char* aInterface,
+ return NS_ERROR_FAILURE;
+ }
+ } else if (!strcmp(aFuncCall, "GetAll")) {
+- const char* param = "";
++ const char* param = "org.freedesktop.NetworkManager.AccessPoint";
+ if (!dbus_message_iter_append_basic(&argsIter, DBUS_TYPE_STRING, &param)) {
+ return NS_ERROR_FAILURE;
+ }
diff --git a/rust-i686.patch b/rust-i686.patch
new file mode 100644
index 000000000000..85512e1436b8
--- /dev/null
+++ b/rust-i686.patch
@@ -0,0 +1,16 @@
+ build/moz.configure/rust.configure | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git c/build/moz.configure/rust.configure i/build/moz.configure/rust.configure
+index cd86b24153debb1b..44911715e25d95e3 100644
+--- c/build/moz.configure/rust.configure
++++ i/build/moz.configure/rust.configure
+@@ -81,7 +81,7 @@ def rust_target(rust_compiler, rustc, target, cross_compiling):
+ # OpenBSD
+ ('x86_64', 'OpenBSD'): 'x86_64-unknown-openbsd',
+ # Linux
+- ('x86', 'Linux'): 'i586-unknown-linux-gnu',
++ ('x86', 'Linux'): 'i686-unknown-linux-gnu',
+ # Linux
+ ('x86_64', 'Linux'): 'x86_64-unknown-linux-gnu',
+ # OS X and iOS