summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Deparis2017-05-12 18:37:02 +0200
committerÉtienne Deparis2017-05-12 18:37:02 +0200
commite026a933a22a2bff3528e37893fcd7dc9d733834 (patch)
tree19cdbf4d053f150e9c6f8b22e5f2e0ea27057d5e
parentf496d019ca8a17504280adcb3702bb2146702958 (diff)
downloadaur-e026a933a22a2bff3528e37893fcd7dc9d733834.tar.gz
Bump to 1.13.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--rust-i686.patch16
3 files changed, 11 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6ecb514dd38..fb3d2ec47fe6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by makepkg 5.0.1
-# Fri Apr 14 11:27:35 UTC 2017
+# Fri May 12 16:36:35 UTC 2017
pkgbase = cliqz
pkgdesc = Firefox-based privacy aware web browser
- pkgver = 1.12.1
+ pkgver = 1.13.0
pkgrel = 1
url = https://cliqz.com/
arch = i686
@@ -14,6 +14,8 @@ pkgbase = cliqz
makedepends = yasm
makedepends = libidl2
makedepends = linux-api-headers
+ makedepends = rust
+ makedepends = cargo
depends = alsa-lib
depends = dbus-glib
depends = ffmpeg
@@ -34,11 +36,9 @@ pkgbase = cliqz
options = !emptydirs
options = !makeflags
options = !strip
- source = https://github.com/cliqz-oss/browser-f/archive/1.12.1.tar.gz
- source = rust-i686.patch
+ source = https://github.com/cliqz-oss/browser-f/archive/1.13.0.tar.gz
source = fix-wifi-scanner.diff
- sha256sums = 638bd90a95d88dfde27916dd423e5e0b62a53de9442e91b2222e4f574648e4d6
- sha256sums = f61ea706ce6905f568b9bdafd1b044b58f20737426f0aa5019ddb9b64031a269
+ sha256sums = 4325c471d215a39c309abe78e3e02b876e1c87f65704daa56fe0c8e3949afa04
sha256sums = 9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8
pkgname = cliqz
diff --git a/PKGBUILD b/PKGBUILD
index 91e78639a878..989d75718243 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=cliqz
_pkgname=browser-f
_vendorname=CLIQZ
-pkgver=1.12.1
+pkgver=1.13.0
pkgrel=1
pkgdesc="Firefox-based privacy aware web browser"
arch=('i686' 'x86_64')
@@ -12,13 +12,12 @@ depends=('alsa-lib' 'dbus-glib' 'ffmpeg' 'gtk2' 'gtk3' 'hunspell'
'icu' 'libevent' 'libvpx' 'libxt' 'mime-types'
'mozilla-common' 'nss' 'sqlite' 'startup-notification'
'ttf-font')
-makedepends=('python2' 'zip' 'autoconf2.13' 'yasm' 'libidl2' 'linux-api-headers')
+makedepends=('python2' 'zip' 'autoconf2.13' 'yasm' 'libidl2'
+ 'linux-api-headers' 'rust' 'cargo')
conflicts=('cliqz-bin')
source=("https://github.com/cliqz-oss/browser-f/archive/${pkgver}.tar.gz"
- "rust-i686.patch"
"fix-wifi-scanner.diff")
-sha256sums=('638bd90a95d88dfde27916dd423e5e0b62a53de9442e91b2222e4f574648e4d6'
- 'f61ea706ce6905f568b9bdafd1b044b58f20737426f0aa5019ddb9b64031a269'
+sha256sums=('4325c471d215a39c309abe78e3e02b876e1c87f65704daa56fe0c8e3949afa04'
'9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8')
options=(!emptydirs !makeflags !strip)
@@ -31,9 +30,6 @@ prepare() {
# https://bugzilla.mozilla.org/show_bug.cgi?id=1314968
patch -Np1 -i $srcdir/fix-wifi-scanner.diff
- # Build with the rust targets we actually ship
- patch -Np1 -i $srcdir/rust-i686.patch
-
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
# get your own set of keys. Feel free to contact foutrelis@archlinux.org for
@@ -84,7 +80,7 @@ build() {
# Hardening is currently deactivated as it hangs on my current machine
# Hardening
- #LDFLAGS+=" -Wl,-z,now"
+ LDFLAGS+=" -Wl,-z,now"
./magic_build_and_package.sh
}
diff --git a/rust-i686.patch b/rust-i686.patch
deleted file mode 100644
index 85512e1436b8..000000000000
--- a/rust-i686.patch
+++ /dev/null
@@ -1,16 +0,0 @@
- build/moz.configure/rust.configure | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git c/build/moz.configure/rust.configure i/build/moz.configure/rust.configure
-index cd86b24153debb1b..44911715e25d95e3 100644
---- c/build/moz.configure/rust.configure
-+++ i/build/moz.configure/rust.configure
-@@ -81,7 +81,7 @@ def rust_target(rust_compiler, rustc, target, cross_compiling):
- # OpenBSD
- ('x86_64', 'OpenBSD'): 'x86_64-unknown-openbsd',
- # Linux
-- ('x86', 'Linux'): 'i586-unknown-linux-gnu',
-+ ('x86', 'Linux'): 'i686-unknown-linux-gnu',
- # Linux
- ('x86_64', 'Linux'): 'x86_64-unknown-linux-gnu',
- # OS X and iOS