summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Harrigan2020-01-23 06:27:55 +0000
committerDavid Harrigan2020-01-23 06:28:27 +0000
commitc187c99e31e7f3834346e0f49883868e7b1bc661 (patch)
tree03ce59e66a6b43a10cebf44031fd108e9b7c934e
downloadaur-c187c99e31e7f3834346e0f49883868e7b1bc661.tar.gz
addpkg: cljstyle-bin 0.11.1-1
Initial Commit.
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore25
-rw-r--r--PKGBUILD19
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f04002796b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = cljstyle-bin
+ pkgdesc = A tool for formatting Clojure code
+ pkgver = 0.11.1
+ pkgrel = 1
+ url = https://github.com/greglook/cljstyle
+ arch = x86_64
+ license = EPL
+ provides = cljstyle
+ conflicts = cljstyle
+ source = https://github.com/greglook/cljstyle/releases/download/0.11.1/cljstyle_0.11.1_linux.tar.gz
+ sha256sums = 690b408fbabfc8e838544a5438c3d6dbf456962be410a4c858697c48ae8dc9b4
+
+pkgname = cljstyle-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..61f6a98822f2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,25 @@
+### Vim ###
+# Swap
+[._]*.s[a-v][a-z]
+[._]*.sw[a-p]
+[._]s[a-rt-v][a-z]
+[._]ss[a-gi-z]
+[._]sw[a-p]
+
+# Session
+Session.vim
+
+# Temporary
+.netrwhist
+*~
+# Auto-generated tag files
+tags
+# Persistent undo
+[._]*.un~
+
+*.zip
+*.tar.gz
+*.xz
+pkg
+src
+tags.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95535be69fd0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: David Harrigan <dharrigan [@] gmail [dot] com>
+
+pkgname=cljstyle-bin
+pkgver=0.11.1
+pkgrel=1
+pkgdesc='A tool for formatting Clojure code'
+arch=('x86_64')
+url='https://github.com/greglook/cljstyle'
+license=('EPL')
+provides=('cljstyle')
+conflicts=('cljstyle')
+
+source=("https://github.com/greglook/cljstyle/releases/download/${pkgver}/${pkgname/\-bin/}_${pkgver/_/-}_linux.tar.gz")
+
+sha256sums=('690b408fbabfc8e838544a5438c3d6dbf456962be410a4c858697c48ae8dc9b4')
+
+package() {
+ install -Dm755 "${srcdir}/${pkgname/\-bin/}" "${pkgdir}/usr/bin/${pkgname/\-bin/}"
+}