summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordryes2015-09-28 16:55:39 +0100
committerdryes2015-09-28 16:55:39 +0100
commit8a9657ef0d0adc08362c02032dfaa1cc7f290142 (patch)
tree4d1061a232b3dc52440e760e4c0cdb7f19652d83
downloadaur-8a9657ef0d0adc08362c02032dfaa1cc7f290142.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7b8c9d085a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v7
+# Mon Sep 28 15:55:30 UTC 2015
+pkgbase = clnns-git
+ pkgdesc = searches and downloads from newznab providers on the command line.
+ pkgver = 9
+ pkgrel = 1
+ url = https://github.com/d2yes/clnns
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ depends = python-feedparser
+ source = git://github.com/d2yes/clnns.git
+ md5sums = SKIP
+
+pkgname = clnns-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6994c2e84e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: dryes <joswiseman@cock.li>
+pkgname='clnns-git'
+pkgver=9
+pkgrel=1
+pkgdesc='searches and downloads from newznab providers on the command line.'
+url='https://github.com/d2yes/clnns'
+arch=('any')
+license=('MIT')
+depends=('python' 'python-feedparser')
+makedepends=('git')
+source=('git://github.com/d2yes/clnns.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ echo $(git rev-list --count master)
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ install -D -m755 "${srcdir}/clnns/clnns.py" "${pkgdir}/usr/bin/clnns"
+}