summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-06-13 00:01:48 -0400
committerKyle Keen2015-06-13 00:01:48 -0400
commit64f0ef91bbf284e3521e8648d1a2a24ad73f3fbc (patch)
treefc39eb8c2cd34f84f6fc2e3c80c7c0172fdf6cb5
downloadaur-64f0ef91bbf284e3521e8648d1a2a24ad73f3fbc.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b36ea18b48e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = clockywock
+ pkgdesc = Analog clock, with alarm and color, for command line.
+ pkgver = 0.3.1a
+ pkgrel = 1
+ url = http://soomka.com/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = ncurses
+ source = http://soomka.com/clockywock-0.3.1a.tar.gz
+ md5sums = 8423ff1b7056dd12ddcf00fb63d96b60
+
+pkgname = clockywock
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0295915da81e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Kyle Keen <keenerd@gmail.com>
+pkgname=clockywock
+pkgver=0.3.1a
+pkgrel=1
+pkgdesc="Analog clock, with alarm and color, for command line."
+arch=('i686' 'x86_64')
+url="http://soomka.com/"
+license=('GPL2')
+depends=('ncurses')
+source=(http://soomka.com/$pkgname-$pkgver.tar.gz)
+md5sums=('8423ff1b7056dd12ddcf00fb63d96b60')
+
+build() {
+ cd "$pkgname-$pkgver"
+ #sed -i 's/timex/&2/g' clockywock.cpp # name clash
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 clockywock "$pkgdir/usr/bin/clockywock"
+ install -Dm644 clockywock.7 "$pkgdir/usr/share/man/man7/clockywock.7"
+}
+