summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Brandwein2019-04-04 00:15:39 -0300
committerEric Brandwein2019-04-04 00:15:39 -0300
commit2415252f94211976f33903b5956fa7f38e85402c (patch)
tree4ec19075abf7e6237cc34c145ba920cca4c332ee
parentcd57e8f48d3681e1c2061b1d93493626fb1096cd (diff)
downloadaur-2415252f94211976f33903b5956fa7f38e85402c.tar.gz
Revert back to v0.21.7
Versions 0.22.1 and 0.22.2 have game-breaking bugs.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
-rw-r--r--SHA1SUM1
-rw-r--r--SHA256SUM1
-rwxr-xr-xclonehero.sh3
5 files changed, 13 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 670de4d47fb4..e43ab68229c6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = clonehero
pkgdesc = Clone of Guitar Hero and Rockband-style games
- pkgver = 0.22.2
+ pkgver = 0.21.7
pkgrel = 1
url = https://clonehero.net/
install = clonehero.install
@@ -8,13 +8,13 @@ pkgbase = clonehero
license = freeware-proprietary
makedepends = megacmd-bin
depends = gtk2
- source = SHA1SUM
+ source = SHA256SUM
source = clonehero.install
source = clonehero.sh
source = clonehero.desktop
- sha256sums = b5f3ecfeb7f8c99d1e828607ad4d1153a177e5059ba317666056fe9598596e58
+ sha256sums = 4bc58ac7cb113d9d0df67a57b27522d0fdd8acdc34b5c86194c01601bf94c92e
sha256sums = 01125237ef90f8435523fed5ae09246a76eb562408c50e76597964b5675385cf
- sha256sums = a985b5761bcc287c627184ea8947b50adf4e208d77e4bb65d15d3d604566c403
+ sha256sums = 6ce5bd0b73e704b7221d8d03a77ffa66d887685ee7e57ccecf704a73caaae53a
sha256sums = a97d85930ac4844b3c5e90d4da8faa7a9b5267909d45be59b1fa39abc76df5fe
pkgname = clonehero
diff --git a/PKGBUILD b/PKGBUILD
index 335f7425f72d..21bd9047aed5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Eric Brandwein <brandweineric at gmail dot com>
# Contributor: 01189998819991197253 <dev.ben01189998819991197253+aur@gmail.com>
pkgname=clonehero
-pkgver=0.22.2
+pkgver=0.21.7
pkgrel=1
pkgdesc="Clone of Guitar Hero and Rockband-style games"
arch=('x86_64')
@@ -10,24 +10,19 @@ license=('freeware-proprietary')
install="$pkgname.install"
makedepends=('megacmd-bin')
depends=('gtk2')
-source=("SHA1SUM"
+source=("SHA256SUM"
"$pkgname.install"
"$pkgname.sh"
"$pkgname.desktop")
-_mega_source_url="https://mega.nz/#!LYMWTKCL!H0YV6PDwFZn_Z-6tpIRFVUoDRp7sw0lKNnDEtXKJf9w"
-sha256sums=('b5f3ecfeb7f8c99d1e828607ad4d1153a177e5059ba317666056fe9598596e58'
+sha256sums=('4bc58ac7cb113d9d0df67a57b27522d0fdd8acdc34b5c86194c01601bf94c92e'
'01125237ef90f8435523fed5ae09246a76eb562408c50e76597964b5675385cf'
- 'a985b5761bcc287c627184ea8947b50adf4e208d77e4bb65d15d3d604566c403'
+ '6ce5bd0b73e704b7221d8d03a77ffa66d887685ee7e57ccecf704a73caaae53a'
'a97d85930ac4844b3c5e90d4da8faa7a9b5267909d45be59b1fa39abc76df5fe')
prepare() {
- mega-get ${_mega_source_url}
- sha1sum --check SHA1SUM
- # Using -P because the tarball has file paths with relative imports.
- mkdir tmp
- mv $pkgname-linux.tar.gz tmp
- cd tmp
- tar -xzPvf $pkgname-linux.tar.gz
+ mega-get https://mega.nz/#!DE8ghYRL!loJZ0poH0QaIlhsuC4mWs7w14M9yP9t_3iTMTKeJchk
+ sha256sum --check SHA256SUM
+ tar -xzvf $pkgname-linux.tar.gz
}
package() {
diff --git a/SHA1SUM b/SHA1SUM
deleted file mode 100644
index d8e74f9a306a..000000000000
--- a/SHA1SUM
+++ /dev/null
@@ -1 +0,0 @@
-7d363b4319a51f768da3ed675ded916f5e4b1053 clonehero-linux.tar.gz
diff --git a/SHA256SUM b/SHA256SUM
new file mode 100644
index 000000000000..eaff99bdd082
--- /dev/null
+++ b/SHA256SUM
@@ -0,0 +1 @@
+8af40e5715fec803ad8661c12e2445fc62f3d37a76f9b51177e68a04eac9bc2a clonehero-linux.tar.gz
diff --git a/clonehero.sh b/clonehero.sh
index 96f84b534138..fa5cee4ce794 100755
--- a/clonehero.sh
+++ b/clonehero.sh
@@ -41,8 +41,7 @@ fi
if [[ "/opt/$pkgname/clonehero_Data" -nt "$HOME/.$pkgname/clonehero_Data" ]]; then
echo "Replacing old data folder"
# This was the name of the data folder before v0.21.7
- rm -rf "$HOME/.$pkgname/Clone Hero_Data"
- rm -rf "$HOME/.$pkgname/clonehero_Data"
+ rm "$HOME/.$pkgname/Clone Hero_Data"
cp -r "/opt/$pkgname/clonehero_Data" "$HOME/.$pkgname/clonehero_Data"
fi