summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicKoehler2022-12-04 09:42:28 +0100
committerNicKoehler2022-12-04 09:42:28 +0100
commitede71a23ec30521495cd306b8061724fd55dd513 (patch)
tree8d4a85f5f4aea3feb6977f6bb75620164cf9fd69
parent369d3f878fe922623b73e3b3eefa30d8cdf9d5d6 (diff)
downloadaur-ede71a23ec30521495cd306b8061724fd55dd513.tar.gz
enlarged the maximum number of open files for the process, thanks to Lucas Melo for the tip!
-rw-r--r--PKGBUILD21
-rwxr-xr-xclonehero7
2 files changed, 17 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 033dc42ed73a..86cfca224cc8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname=clonehero
pkgver=1.0.0.4080
-pkgrel=2
-pkgdesc="Clone of Guitar Hero and Rockband-style games"
+pkgrel=3
+pkgdesc="Clone Hero is a classic instrument based rhythm game for Windows, Mac, Linux, and Android. It's playable with any 5 or 6 fret guitar controller, any midi drum kit, any game controller and even your keyboard! Jam out with Drums, 5-fret Guitar, or 6-fret Guitar online or local!"
arch=('x86_64')
url="https://clonehero.net/"
license=('freeware-proprietary')
@@ -13,26 +13,25 @@ install="$pkgname.install"
depends=('gtk2')
source=("${pkgname}-${pkgver}.tar.gz"::"https://pubdl.clonehero.net/clonehero-v$pkgver-final/clonehero-linux.tar.xz"
"$pkgname.install"
- "$pkgname.desktop")
-sha1sums=('135788e5e99aef454252c0bae8fa88daca338a63'
- 'SKIP'
- 'SKIP')
-sha256sums=('SKIP'
+ "$pkgname.desktop"
+ "$pkgname")
+
+sha256sums=('6162d5fb0810f517ca45249687fc743cc8c1ead140e18a476fd5ad60e3a06592'
'01125237ef90f8435523fed5ae09246a76eb562408c50e76597964b5675385cf'
- 'a97d85930ac4844b3c5e90d4da8faa7a9b5267909d45be59b1fa39abc76df5fe')
+ 'a97d85930ac4844b3c5e90d4da8faa7a9b5267909d45be59b1fa39abc76df5fe'
+ 'e152f18dc38f47c0b0c52ff4227c7daa2fa5251fdf7f86683df1cd8274b24cb6')
package() {
- mkdir -p "$pkgdir/usr/bin"
install -dm755 "$pkgdir/opt/"
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+
cp -r "$srcdir/$pkgname-linux" "$pkgdir/opt/$pkgname"
find "$pkgdir/opt/$pkgname" -type d -exec chmod 755 {} +
find "$pkgdir/opt/$pkgname" -type f -exec chmod 644 {} +
chmod +x "$pkgdir/opt/$pkgname/$pkgname"
- ln -s -f "/opt/$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
# Install script, .desktop launcher with icon
install -Dm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
install -Dm644 "$srcdir/$pkgname-linux/clonehero_Data/Resources/UnityPlayer.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
}
-
diff --git a/clonehero b/clonehero
new file mode 100755
index 000000000000..90882aa488dc
--- /dev/null
+++ b/clonehero
@@ -0,0 +1,7 @@
+#!/bin/bash
+
+# We need to increase the open file limit otherwise the game eventually crashes
+# or softlocks with the log pointing to IOExceptions refering to "too many open
+# files".
+ulimit -Sn 8192
+exec '/opt/clonehero/clonehero' "$@"