summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormuhviehstah2016-07-12 20:17:50 +0200
committermuhviehstah2016-07-12 20:17:50 +0200
commit93dc9fc1ffe160948f0b0f2bc9d7905ff48d89ad (patch)
treed92a14eef13c118ae02afd7730535f30b80fdcd2
parentf00a453c4eb3c08a90581558cc1c499e61d4e5fa (diff)
downloadaur-93dc9fc1ffe160948f0b0f2bc9d7905ff48d89ad.tar.gz
fix
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD9
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20c9e1fd7b15..9335585ba28a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,6 @@ pkgbase = cloog-git
arch = i686
arch = x86_64
license = GPL
- depends = isl
provides = isl15
provides = cloog
source = cloog-0.18.4::git+http://repo.or.cz/cloog.git#branch=master
diff --git a/PKGBUILD b/PKGBUILD
index 30e82376efb1..9fd945cfdcfe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,20 @@
# Contributor: Allan McRae <allan@archlinux.org>
pkgname=cloog-git
+_origpkgname=cloog
pkgver=0.18.4
pkgrel=2
pkgdesc="Library that generates loops for scanning polyhedra"
arch=('i686' 'x86_64')
url="http://www.bastoul.net/cloog/"
license=('GPL')
-depends=('isl')
+depends=('')
source=('cloog-0.18.4::git+http://repo.or.cz/cloog.git#branch=master')
provides=('isl15' 'cloog')
md5sums=('SKIP')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${_origpkgname}-${pkgver}"
git submodule init
git submodule update --recursive
sh autogen.sh
@@ -23,13 +24,13 @@ build() {
}
check() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${_origpkgname}-${pkgver}"
# There are certain race conditions on running the tests, so we restrict
# it to one job (one CPU core).
make -j1 check
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${_origpkgname}-${pkgver}"
make DESTDIR=$pkgdir/ install
}