summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmls2015-07-09 16:43:48 +0200
committersmls2015-07-09 16:43:48 +0200
commit0aeda188115fc3a18882e688ce81f2392fadba0d (patch)
tree73ed99eac4587b4e1b37454f6f2fd3c65c67a8cc
downloadaur-0aeda188115fc3a18882e688ce81f2392fadba0d.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD50
-rw-r--r--closure-hib.desktop10
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..99cc4739e44d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = closure-hib
+ pkgdesc = A puzzle platformer game that centers around light (Humble Bundle version)
+ pkgver = 1.1_20121228
+ pkgrel = 2
+ url = http://closuregame.com/
+ arch = i686
+ arch = x86_64
+ license = custom:commercial
+ depends = libgl
+ depends = sdl
+ depends = nvidia-cg-toolkit
+ depends = openal
+ depends = freealut
+ options = !strip
+ options = !upx
+ source = hib://Closure-Linux-1.1-2012-12-28.sh
+ source = closure-hib.desktop
+ md5sums = a7c2f7fe17ff67f376da70611abdce97
+ md5sums = d691e2d56865f8331999374684bdf354
+
+pkgname = closure-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38689b41bdd4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Sam S. <smls75@gmail.com>
+
+pkgname=closure-hib
+pkgver=1.1_20121228
+_hibver=1.1-2012-12-28
+pkgrel=2
+pkgdesc='A puzzle platformer game that centers around light (Humble Bundle version)'
+url='http://closuregame.com/'
+arch=('i686' 'x86_64')
+license=('custom:commercial')
+depends=('libgl' 'sdl' 'nvidia-cg-toolkit' 'openal' 'freealut')
+options=('!strip' '!upx')
+PKGEXT='.pkg.tar'
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+_installer="Closure-Linux-${_hibver}.sh"
+source=("hib://${_installer}"
+ 'closure-hib.desktop')
+md5sums=('a7c2f7fe17ff67f376da70611abdce97'
+ 'd691e2d56865f8331999374684bdf354')
+
+package() {
+ cd $srcdir
+ _target="${pkgdir}/opt/Closure"
+ [ $CARCH == "i686" ] && _arch='x86' || _arch='x86_64'
+
+ # Extract installer
+ [[ -d archive ]] && rm -r archive; mkdir archive; mkdir -p ${_target}
+ while read line; do echo -n '.'; done < <( # show progress as dots
+ sh "${_installer}" --tar xvf -C archive/
+ lzma -d < archive/instarchive_linux_${_arch} | tar xvf - -C "${_target}"
+ lzma -d < archive/instarchive_all | tar xvf - -C "${_target}"
+ ); echo
+
+ # Fix permissions and remove unused files with encoding problems
+ rm -r "${_target}/resources/textures/ui/temp/"
+ chown root:root -R "${_target}"
+
+ # Install desktop entry
+ install -Dm644 "${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ # Install icon
+ install -Dm644 "${_target}/Closure.png" \
+ "${pkgdir}/usr/share/pixmaps/closure.png"
+
+ # Install launch script
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/opt/Closure/Closure.bin.${_arch}" "${pkgdir}/usr/bin/closure"
+}
diff --git a/closure-hib.desktop b/closure-hib.desktop
new file mode 100644
index 000000000000..22e5c4b2f570
--- /dev/null
+++ b/closure-hib.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Categories=Game;
+Name=Closure
+Comment=Eyebrow Interactive
+GenericName=Platformer Puzzle Game
+Icon=closure
+Exec=/usr/bin/closure
+Terminal=false