summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉtienne Lafarge2019-02-12 12:39:29 +0100
committerÉtienne Lafarge2019-02-12 12:43:04 +0100
commit0fcc10a6171eff2810bfa4f57bd829afe5ddf0b3 (patch)
tree7638171f101e69eb4b26cea185c18081d8c22f41
parent5757bed80835a4396b178528f80ac018484a810d (diff)
downloadaur-0fcc10a6171eff2810bfa4f57bd829afe5ddf0b3.tar.gz
[v18.5-3] Add missing dependencies
As noted by antoinemartin, pkgconf is required during the build phase for systemd units to be dropped in the appropriate folder. Also, cloud-init requires dhclient as stated here: https://github.com/cloud-init/cloud-init/blob/ad170db966492e845b9dc23346cc7297e8a99032/cloudinit/net/dhcp.py#L127 This runtime dependency has also been added.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24d2813dd015..198222ef7f69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = cloud-init
pkgdesc = The standard for customising cloud instances
pkgver = 18.5
- pkgrel = 1
+ pkgrel = 3
url = https://cloud-init.io
arch = any
license = GPL3
makedepends = python2
makedepends = python2-setuptools
+ makedepends = pkgconf
depends = systemd
depends = sudo
depends = python2-yaml
@@ -23,12 +24,13 @@ pkgbase = cloud-init
depends = python2-argparse
depends = python2-oauthlib
depends = python2-jinja
+ depends = dhclient
backup = etc/cloud/cloud.cfg
backup = etc/cloud/cloud.cfg.d/05_logging.cfg
- source = https://launchpad.net/cloud-init/trunk/18.2/+download/cloud-init-18.2.tar.gz
+ source = https://launchpad.net/cloud-init/trunk/18.5/+download/cloud-init-18.5.tar.gz
source = fix-lib.patch
source = archlinux.cloud.cfg
- sha256sums = 0224969ebdae6eadffc5f40823bb206d8b05d99a1b730018535102f38b155249
+ sha256sums = 650d1eb38ea488b3ea8cc9d7b0fb975bb3c9a3e5ca7dcaf924892f5f9813da92
sha256sums = 0ace6a9e4156145e5b50bd5fa75d6aeefe8e5c10a63f8d9e0d3c7be4c9b53942
sha256sums = 109dd4500593c2fb7b2f7bf05eaf1835be8062c4f7b3025a0371184a691950da
diff --git a/PKGBUILD b/PKGBUILD
index f2db290d2a7d..ffba8aa99617 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=cloud-init
pkgver=18.5
-pkgrel=1
+pkgrel=3
pkgdesc="The standard for customising cloud instances"
arch=('any')
url="https://cloud-init.io"
@@ -14,8 +14,8 @@ depends=('systemd' 'sudo' 'python2-yaml' 'python2-cheetah' 'python2-prettytable'
'python2-oauth' 'python2-boto' 'python2-configobj'
'python2-jsonschema' 'python2-jsonpatch' 'python2-jsonpointer' 'net-tools'
'python2-requests' 'python2-argparse' 'python2-oauthlib'
- 'python2-jinja')
-makedepends=('python2' 'python2-setuptools')
+ 'python2-jinja' 'dhclient')
+makedepends=('python2' 'python2-setuptools' 'pkgconf')
backup=('etc/cloud/cloud.cfg' 'etc/cloud/cloud.cfg.d/05_logging.cfg')
source=("https://launchpad.net/$pkgname/trunk/$pkgver/+download/$pkgname-$pkgver.tar.gz"
fix-lib.patch