summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2017-03-18 19:31:29 +0100
committerbartus2017-03-18 19:31:29 +0100
commit62de6321c29d1523c31135bdf0cee06d59871bbd (patch)
tree63c186ab8f4d751e364b0e776290584bfd50865d
parente7b9187dde2ba3f8e042d2feb2d90ff0fa13660a (diff)
downloadaur-62de6321c29d1523c31135bdf0cee06d59871bbd.tar.gz
new version, reformat, include missing makedep
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8edb8e84544..e28a99b39792 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cloudcompare-git
pkgdesc = A 3D point cloud (and triangular mesh) processing software
- pkgver = pkgver=2.6.2.r818.g51fb204
+ pkgver = 2.8.0.r112.g26401405
pkgrel = 1
url = http://www.danielgm.net/cc/
arch = i686
@@ -10,12 +10,13 @@ pkgbase = cloudcompare-git
makedepends = cmake
makedepends = pcl
makedepends = doxygen
+ makedepends = liblas
depends = qt5-base
depends = glu
depends = mesa
optdepends = pcl
- optdepends = liblas
- source = git+https://github.com/cloudcompare/trunk
+ optdepends = liblas
+ source = cloudcompare::git+https://github.com/CloudCompare/CloudCompare.git
md5sums = SKIP
pkgname = cloudcompare-git
diff --git a/PKGBUILD b/PKGBUILD
index cce9ad6c6860..13a2a8e6d9ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
# Original Author: Johannes Sauer <joh.sauer(at)gmail(dot)com>
# Maintainer: Danilo Bargen <aur at dbrgn dot ch>
-pkgname=cloudcompare-git
-pkgver=2.6.2.r818.g51fb204
+name=cloudcompare
+pkgname=${name}-git
+pkgver=2.8.0.r112.g26401405
pkgrel=1
pkgdesc="A 3D point cloud (and triangular mesh) processing software"
arch=('i686' 'x86_64')
url="http://www.danielgm.net/cc/"
license=('GPL2')
depends=('qt5-base' 'glu' 'mesa')
-makedepends=('git' 'cmake' 'pcl' 'doxygen')
+makedepends=('git' 'cmake' 'pcl' 'doxygen' 'liblas')
optdepends=('pcl' 'liblas')
-source=("git+https://github.com/cloudcompare/trunk")
+source=("${name}::git+https://github.com/CloudCompare/CloudCompare.git")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/trunk"
- git describe --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+ cd ${srcdir}/${name}
+ git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/trunk"
+ cd ${srcdir}/${name}
- [[ -d build ]] && rm -r build
mkdir -p build && cd build
cmake .. \
@@ -44,10 +44,11 @@ build() {
-DOPTION_USE_LIBLAS=ON \
-DLIBLAS_INCLUDE_DIR=/usr/include/liblas/ \
-DLIBLAS_RELEASE_LIBRARY_FILE=/usr/lib/liblas.so
- make -j$(nproc)
+ make
}
package() {
- cd "$srcdir/trunk/build"
+ cd ${srcdir}/${name}/build
make DESTDIR="$pkgdir/" install
}
+# vim:set sw=2 ts=2 et: