summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-03-27 07:57:54 +0100
committerbartus2019-03-27 07:57:54 +0100
commit96204f6d9cfbb7d6d990987dcbf599110d24af5c (patch)
tree8b632981a95823d9200b079fc62d0e3ae135374a
parent6b850862cff2d99a0efd9e6eb27103360fe0f3fe (diff)
downloadaur-96204f6d9cfbb7d6d990987dcbf599110d24af5c.tar.gz
refactor $$-git package
pin source with tag remove commit from pkgver
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f731f816f206..742f04f4e2f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = cloudcompare-git
+pkgbase = cloudcompare
pkgdesc = A 3D point cloud (and triangular mesh) processing software
- pkgver = 2.10.2.r115.g75157a8d
+ pkgver = 2.10.2
pkgrel = 1
url = http://www.danielgm.net/cc/
arch = i686
@@ -25,10 +25,10 @@ pkgbase = cloudcompare-git
depends = cgal
depends = pdal
optdepends = pcl
- source = cloudcompare::git+https://github.com/CloudCompare/CloudCompare.git
+ source = cloudcompare::git+https://github.com/CloudCompare/CloudCompare.git#tag=v2.10.2
source = constexpr.patch
md5sums = SKIP
md5sums = c1ea23f8a38cf1326196bb42de07e020
-pkgname = cloudcompare-git
+pkgname = cloudcompare
diff --git a/PKGBUILD b/PKGBUILD
index d872b0a61291..4e67dd33e6ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
# Maintainer: Danilo Bargen <aur at dbrgn dot ch>
name=cloudcompare
-pkgname=${name}-git
-pkgver=2.10.2.r115.g75157a8d
+pkgname=${name}
+_fragment="#tag=v2.10.2"
+pkgver=2.10.2
pkgrel=1
pkgdesc="A 3D point cloud (and triangular mesh) processing software"
arch=('i686' 'x86_64')
@@ -12,7 +13,7 @@ license=('GPL2')
depends=('qt5-base' 'qt5-tools' 'qt5-svg' 'glu' 'glew' 'mesa' 'vxl' 'ffmpeg' 'cgal' 'pdal')
makedepends=('git' 'cmake' 'pcl' 'libharu' 'proj' 'python' 'doxygen' 'laz-perf')
optdepends=('pcl')
-source=("${name}::git+https://github.com/CloudCompare/CloudCompare.git"
+source=("${name}::git+https://github.com/CloudCompare/CloudCompare.git${_fragment}"
"constexpr.patch"
)
md5sums=('SKIP'
@@ -21,12 +22,11 @@ md5sums=('SKIP'
prepare() {
cd ${srcdir}/${name}
git submodule update --init --recursive
- git apply ${srcdir}/constexpr.patch
}
pkgver() {
cd ${srcdir}/${name}
- git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+ git describe --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
build() {
@@ -43,9 +43,7 @@ build() {
-DINSTALL_QCOMPASS_PLUGIN=ON \
-DINSTALL_QPCL_PLUGIN=ON \
-DINSTALL_QBLUR_PLUGIN=ON \
- -DCMAKE_BUILD_TYPE=Release \
- -DCOMPILE_CC_CORE_LIB_WITH_CGAL=ON \
- -DINSTALL_QHPR_PLUGIN=ON \
+ -DCMAKE_BUILD_TYPE=Release \ -DCOMPILE_CC_CORE_LIB_WITH_CGAL=ON \ -DINSTALL_QHPR_PLUGIN=ON \
-DINSTALL_QPOISSON_RECON_PLUGIN=ON \
-DPOISSON_RECON_WITH_OPEN_MP=ON \
-DINSTALL_QEDL_PLUGIN=ON \