summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2021-10-11 13:49:09 +0200
committerbartus2021-10-11 13:49:09 +0200
commit9b3a1ed5fe9de44972ddd71f0796100e9764b635 (patch)
treed5dca73767c22d1b82adcdaba1eee595f163239c
parent2809860e3c42cb10fb70f0d57a2be3bd40ebd695 (diff)
downloadaur-9b3a1ed5fe9d.tar.gz
Port upstream pcl changes
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--pcl.patch24
3 files changed, 5 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b235fed539d0..2b20eb20c63a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cloudcompare
pkgdesc = A 3D point cloud (and triangular mesh) processing software
pkgver = 2.11.3
- pkgrel = 4
+ pkgrel = 5
url = http://www.danielgm.net/cc/
arch = i686
arch = x86_64
@@ -36,7 +36,6 @@ pkgbase = cloudcompare
source = cloudcompare-cork::git+https://github.com/CloudCompare/cork.git
source = constexpr.patch
source = cork.patch
- source = pcl.patch
source = CloudCompare.desktop
source = ccViewer.desktop
source = pdal_230.patch
@@ -44,7 +43,6 @@ pkgbase = cloudcompare
sha256sums = SKIP
sha256sums = 984e6186f6483534a52cb153b65dee016904eb9efdb89211c2c0042eea2417ff
sha256sums = 1789d726d65478857633fa4797da7c3ea4c13d90cdcc169d4197c58d2d33f123
- sha256sums = 183f05dee316bdf7c6e9935e2a21b79b2172f61df5b0b6954bcd0d74751afc64
sha256sums = 14096df9cf7aca3099d5df1585d1cf669544e9b10754dce3d2507100dd7034fe
sha256sums = 821ac2540e1196774e26f8033946ce7b36223dae7a2a7c78f4a901b4177f68cc
sha256sums = 70e5c6e932c1cf61dc9add064c2e165737db26a5fdda696c2e9cf92cbfd257c6
diff --git a/PKGBUILD b/PKGBUILD
index 9e0bf54b5adc..fd4f67deef28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ name=cloudcompare
_fragment="#tag=v2.11.3"
pkgname=${name}
pkgver="${_fragment###tag=v}"
-pkgrel=4
+pkgrel=5
pkgdesc="A 3D point cloud (and triangular mesh) processing software"
arch=('i686' 'x86_64')
url="http://www.danielgm.net/cc/"
@@ -21,7 +21,6 @@ source=("${name}::git+https://github.com/CloudCompare/CloudCompare.git${_fragmen
"${name}-cork::git+https://github.com/CloudCompare/cork.git"
constexpr.patch
cork.patch
- pcl.patch
CloudCompare.desktop
ccViewer.desktop
pdal_230.patch
@@ -30,17 +29,18 @@ sha256sums=('SKIP'
'SKIP'
'984e6186f6483534a52cb153b65dee016904eb9efdb89211c2c0042eea2417ff'
'1789d726d65478857633fa4797da7c3ea4c13d90cdcc169d4197c58d2d33f123'
- '183f05dee316bdf7c6e9935e2a21b79b2172f61df5b0b6954bcd0d74751afc64'
'14096df9cf7aca3099d5df1585d1cf669544e9b10754dce3d2507100dd7034fe'
'821ac2540e1196774e26f8033946ce7b36223dae7a2a7c78f4a901b4177f68cc'
'70e5c6e932c1cf61dc9add064c2e165737db26a5fdda696c2e9cf92cbfd257c6')
prepare() {
git -C "${srcdir}/${name}" submodule update --init --recursive
- git -C "${srcdir}/${name}" apply -v "${srcdir}"/{constexpr,pcl,pdal_230}.patch
+ git -C "${srcdir}/${name}" apply -v "${srcdir}"/{constexpr,pdal_230}.patch
git -C "${srcdir}/${name}-cork" apply -v "${srcdir}"/cork.patch
#fix gcc:11 porting
sed '1 i\#include <limits>' -i "${srcdir}/${name}"/plugins/core/IO/qE57IO/extern/libE57Format/src/E57XmlParser.cpp
+ #fix pcl
+ git -C "${srcdir}/${name}" cherry-pick -n 535c5017604b69b48f7a03de47d9a0c35cbdbb65 5bc453a08a4760cf63788461e5160b2644d4588c 1b5f2a710e10138aa39f5779ce66f4b0321f5d4b 6a398d53cd1c3f960aa0f9ffa748374aa518d89b
}
build() {
diff --git a/pcl.patch b/pcl.patch
deleted file mode 100644
index 9120989acbb3..000000000000
--- a/pcl.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/plugins/core/Standard/qPCL/PclUtils/filters/MLSSmoothingUpsampling.cpp b/plugins/core/Standard/qPCL/PclUtils/filters/MLSSmoothingUpsampling.cpp
-index 59c803c9..04a23edf 100644
---- a/plugins/core/Standard/qPCL/PclUtils/filters/MLSSmoothingUpsampling.cpp
-+++ b/plugins/core/Standard/qPCL/PclUtils/filters/MLSSmoothingUpsampling.cpp
-@@ -25,6 +25,7 @@
-
- //PCL
- #include <pcl/surface/mls.h>
-+#include <pcl/search/kdtree.h>
-
- //qCC_plugins
- #include <ccMainAppInterface.h>
-diff --git a/plugins/core/Standard/qPCL/PclUtils/utils/my_point_types.h b/plugins/core/Standard/qPCL/PclUtils/utils/my_point_types.h
-index 3128e838..7f5cd7f4 100644
---- a/plugins/core/Standard/qPCL/PclUtils/utils/my_point_types.h
-+++ b/plugins/core/Standard/qPCL/PclUtils/utils/my_point_types.h
-@@ -21,6 +21,7 @@
- //PCL
- #include <pcl/register_point_struct.h>
- #include <pcl/point_types.h>
-+#include <boost/cstdint.hpp>
-
- //! PCL custom point type used for reading RGB data
- struct OnlyRGB