summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkikislater2022-06-14 21:34:19 +0400
committerkikislater2022-06-14 21:34:19 +0400
commitb741bacb5f62a7a41f2c40906b21a5ed78db05cd (patch)
tree502d152a0864daffa1ac971acf01e3cceab03c07
parent45d4d43b70c0749e591c0e667e430570e7b51228 (diff)
downloadaur-b741bacb5f62a7a41f2c40906b21a5ed78db05cd.tar.gz
Uptstream update to 2.12.3 and CGAL option correction
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed391b7563b0..6c557ec25127 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cloudcompare
pkgdesc = A 3D point cloud (and triangular mesh) processing software
- pkgver = 2.12.2
+ pkgver = 2.12.3
pkgrel = 1
url = http://www.danielgm.net/cc/
arch = i686
@@ -32,7 +32,7 @@ pkgbase = cloudcompare
depends = tbb
depends = gdal
optdepends = pcl
- source = cloudcompare::git+https://github.com/CloudCompare/CloudCompare.git#tag=v2.12.2
+ source = cloudcompare::git+https://github.com/CloudCompare/CloudCompare.git#tag=v2.12.3
source = cloudcompare-cork::git+https://github.com/CloudCompare/cork.git
source = CloudCompare.desktop
source = ccViewer.desktop
diff --git a/PKGBUILD b/PKGBUILD
index 06610d40abe7..89c5130b4f56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# shellcheck disable=SC2034,SC2154 # allow unused/uninitialized variables.
name=cloudcompare
-_fragment="#tag=v2.12.2"
+_fragment="#tag=v2.12.3"
pkgname=${name}
pkgver="${_fragment###tag=v}"
pkgrel=1
@@ -40,8 +40,8 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr
-DCMAKE_INSTALL_LIBDIR=lib
-DCMAKE_BUILD_TYPE=Release
- -DCOMPILE_CC_CORE_LIB_WITH_CGAL=ON
- -DCOMPILE_CC_CORE_LIB_WITH_TBB=OFF
+ -DCCCORELIB_USE_CGAL:BOOL=ON
+ -DCCCORELIB_USE_TBB:BOOL=OFF
-DWITH_FFMPEG_SUPPORT:BOOL=ON
-DFFMPEG_INCLUDE_DIR:PATH=/usr/include/ffmpeg4.4
-DFFMPEG_LIBRARY_DIR:PATH=/usr/lib/ffmpeg4.4
@@ -63,8 +63,7 @@ build() {
-DPLUGIN_IO_QRDB:BOOL=OFF # requires rdblib (package for AUR from http://www.riegl.com/products/software-packages/rdblib/)
-DPLUGIN_STANDARD_QANIMATION:BOOL=ON
-DPLUGIN_STANDARD_QBROOM:BOOL=ON
- -DPLUGIN_STANDARD_QCANUPO:BOOL=ON # requires dlib
- -DDLIB_ROOT:PATH="/usr" # required by qcanupo plugin
+ -DPLUGIN_STANDARD_QCANUPO:BOOL=ON # requires dlib-DDLIB_ROOT:PATH="/usr" # required by qcanupo plugin
-DPLUGIN_STANDARD_QCOMPASS:BOOL=ON
-DPLUGIN_STANDARD_QCORK:BOOL=ON # require mpir, cork (cork-git is not enough)
-DMPIR_INCLUDE_DIR:PATH=/usr/include # required by qcork plugin