summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchmad Fathoni2022-07-16 09:28:46 +0700
committerAchmad Fathoni2022-07-16 09:28:46 +0700
commite47cfcba71ecff46e6447b32c3ea010d2d7271aa (patch)
tree71cacad997c31a5a772ac53dda642821e5d0fc49
parentd36dfa8476a5c50bdf4035b2bf2d5d044ceafc26 (diff)
downloadaur-e47cfcba71ecff46e6447b32c3ea010d2d7271aa.tar.gz
2.12.4
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
-rw-r--r--tbb.2021.cccorelib.patch25
3 files changed, 6 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 556e5d545681..7e9101f456e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cloudcompare
pkgdesc = A 3D point cloud (and triangular mesh) processing software
- pkgver = 2.12.3
- pkgrel = 3
+ pkgver = 2.12.4
+ pkgrel = 1
url = http://www.danielgm.net/cc/
arch = i686
arch = x86_64
@@ -32,12 +32,11 @@ pkgbase = cloudcompare
depends = tbb
depends = gdal
optdepends = pcl
- source = cloudcompare::git+https://github.com/CloudCompare/CloudCompare.git#tag=v2.12.3
+ source = cloudcompare::git+https://github.com/CloudCompare/CloudCompare.git#tag=v2.12.4
source = cloudcompare-cork::git+https://github.com/CloudCompare/cork.git
source = CloudCompare.desktop
source = ccViewer.desktop
source = tbb.2021.patch
- source = tbb.2021.cccorelib.patch
source = libE57Format::git+https://github.com/asmaloney/libE57Format
source = CCCoreLib::git+https://github.com/CloudCompare/CCCoreLib
source = PoissonRecon::git+https://github.com/cloudcompare/PoissonRecon
@@ -59,6 +58,5 @@ pkgbase = cloudcompare
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = SKIP
pkgname = cloudcompare
diff --git a/PKGBUILD b/PKGBUILD
index 452fe56a0bbd..57fdf82d20bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,10 +6,10 @@
# shellcheck disable=SC2034,SC2154 # allow unused/uninitialized variables.
name=cloudcompare
-_fragment="#tag=v2.12.3"
+_fragment="#tag=v2.12.4"
pkgname=${name}
pkgver="${_fragment###tag=v}"
-pkgrel=3
+pkgrel=1
pkgdesc="A 3D point cloud (and triangular mesh) processing software"
arch=('i686' 'x86_64')
url="http://www.danielgm.net/cc/"
@@ -21,14 +21,12 @@ source=("${name}::git+https://github.com/CloudCompare/CloudCompare.git${_fragmen
"${name}-cork::git+https://github.com/CloudCompare/cork.git"
CloudCompare.desktop
ccViewer.desktop
- tbb.2021.patch
- tbb.2021.cccorelib.patch)
+ tbb.2021.patch)
sha256sums=('SKIP'
'SKIP'
'14096df9cf7aca3099d5df1585d1cf669544e9b10754dce3d2507100dd7034fe'
'821ac2540e1196774e26f8033946ce7b36223dae7a2a7c78f4a901b4177f68cc'
'f10ac084b1ec626c7a9c51e09faf87054edd0c069f4114334d9b1ed664a16ff1'
- 'c4549314b559f61878f63ea9d98aa6da0df3cb7bf8dff709ba089494ab58a32f'
'SKIP'
'SKIP'
'SKIP'
@@ -42,7 +40,6 @@ prepare() {
prepare_submodule
# sed "/CXX_STANDARD/s/14/17/" -i "${srcdir}/${name}"/cmake/CMakeSetCompilerOptions.cmake
git -C "${srcdir}/${name}" apply -v "${srcdir}"/tbb.2021.patch
- git -C "${srcdir}/${name}/libs/qCC_db/extern/CCCoreLib" apply -v "${srcdir}"/tbb.2021.cccorelib.patch
}
build() {
diff --git a/tbb.2021.cccorelib.patch b/tbb.2021.cccorelib.patch
deleted file mode 100644
index f5e3646b311a..000000000000
--- a/tbb.2021.cccorelib.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From ee76a1fcd305705e37d7d46b7670b0f58067c363 Mon Sep 17 00:00:00 2001
-From: bartus <szczepaniak.bartek+github@gmail.com>
-Date: Sat, 25 Jun 2022 16:25:49 +0200
-Subject: [PATCH] tbb:2021 use targets instead of the library list
-
----
- CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 5dcc04c..965c3a5 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -169,7 +169,7 @@ if ( CCCORELIB_USE_TBB )
- if ( TBB_FOUND )
- target_link_libraries( CCCoreLib
- PUBLIC
-- ${TBB_IMPORTED_TARGETS}
-+ TBB::tbb
- )
-
- target_compile_definitions( CCCoreLib
---
-2.36.1
-