summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAbrarSyed2018-10-23 23:06:07 -0500
committerAbrarSyed2018-10-23 23:06:07 -0500
commited0961756e62018335973c619057f87b0e68c467 (patch)
treee79cda9e59bea489eb6f0de60067f7408daa404c
parentc4e19b732be8c7dfd66f864aa707655c101bd60a (diff)
downloadaur-ed0961756e62018335973c619057f87b0e68c467.tar.gz
dropped i686 and updated to v6.40.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 16 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1269d2a6c7f4..5cc64b6baddf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,18 @@
# Generated by mksrcinfo v8
-# Sat Sep 29 02:24:49 UTC 2018
+# Wed Oct 24 04:03:53 UTC 2018
pkgbase = cloudfoundry-cli
pkgdesc = The official command line client for Cloud Foundry
- pkgver = 6.39.1
+ pkgver = 6.40.0
pkgrel = 1
url = https://github.com/cloudfoundry/cli
- arch = i686
arch = x86_64
license = Apache
options = !emptydirs
options = !strip
- source = license.txt::https://raw.githubusercontent.com/cloudfoundry/cli/v6.39.1/LICENSE
- md5sums = 3b83ef96387f14655fc854ddc3c6bd57
- sha256sums = cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30
- source_i686 = cf-cli-6.39.1-i686.tar.gz::https://cli.run.pivotal.io/stable?release=linux32-binary&version=6.39.1&source=github-rel
- md5sums_i686 = 54e018500840606b1e48d681ecb718f8
- sha256sums_i686 = 28380bc847e3942a451376038c92241cef41e5e93407a059129c9cd87a810220
- source_x86_64 = cf-cli-6.39.1-amd64.tar.gz::https://cli.run.pivotal.io/stable?release=linux64-binary&version=6.39.1&source=github-rel
- md5sums_x86_64 = f417532f0569c18353c13664de861fec
- sha256sums_x86_64 = 62c3930b139c71334ad6b69fddc7fa469558873995877ed8bbfdf07e170d1d3e
+ source = cf-cli-6.40.0-amd64.tar.gz::https://cli.run.pivotal.io/stable?release=linux64-binary&version=6.40.0&source=github-rel
+ md5sums = 2d775f4935bff51b817e885b546662d4
+ sha256sums = de34bb9755ec9f9ca9605b14c690a9013157cc3c83fc647beb2c842a03c8b5b2
+ sha512sums = 7084d48dfe2216ec5304d2f4009167bdea6328e5c9cc0d1f8eee33eedcca7e52834d7673fcdd5b700391cd35b4a610eae10a92447ee48b5a3fd99585042d8a93
pkgname = cloudfoundry-cli
diff --git a/PKGBUILD b/PKGBUILD
index 71287fcadf40..ec4cbcaa1284 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,28 @@
# Maintainer: AbrarSyed <aur@abrarsyed.com>
pkgname=cloudfoundry-cli
-pkgver=6.39.1
+pkgver=6.40.0
pkgrel=1
pkgdesc="The official command line client for Cloud Foundry"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://github.com/cloudfoundry/cli"
license=('Apache')
provides=()
options=('!emptydirs' '!strip')
-source=("license.txt::https://raw.githubusercontent.com/cloudfoundry/cli/v${pkgver}/LICENSE")
-source_i686=("cf-cli-${pkgver}-i686.tar.gz::https://cli.run.pivotal.io/stable?release=linux32-binary&version=${pkgver}&source=github-rel")
-source_x86_64=("cf-cli-${pkgver}-amd64.tar.gz::https://cli.run.pivotal.io/stable?release=linux64-binary&version=${pkgver}&source=github-rel")
+source=("cf-cli-${pkgver}-amd64.tar.gz::https://cli.run.pivotal.io/stable?release=linux64-binary&version=${pkgver}&source=github-rel")
-md5sums=('3b83ef96387f14655fc854ddc3c6bd57')
-md5sums_i686=('54e018500840606b1e48d681ecb718f8')
-md5sums_x86_64=('f417532f0569c18353c13664de861fec')
-sha256sums=('cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30')
-sha256sums_i686=('28380bc847e3942a451376038c92241cef41e5e93407a059129c9cd87a810220')
-sha256sums_x86_64=('62c3930b139c71334ad6b69fddc7fa469558873995877ed8bbfdf07e170d1d3e')
+md5sums=('2d775f4935bff51b817e885b546662d4')
+sha256sums=('de34bb9755ec9f9ca9605b14c690a9013157cc3c83fc647beb2c842a03c8b5b2')
+sha512sums=('7084d48dfe2216ec5304d2f4009167bdea6328e5c9cc0d1f8eee33eedcca7e52834d7673fcdd5b700391cd35b4a610eae10a92447ee48b5a3fd99585042d8a93')
package() {
# copy binary
mkdir -p "$pkgdir/usr/bin"
install $srcdir/cf "$pkgdir/usr/bin"
- #copy license
+ #copy license & notice
mkdir -p "$pkgdir/usr/share/doc/cf-cli"
- install license.txt "$pkgdir/usr/share/doc/cf-cli/copyright"
+ install $srcdir/LICENSE "$pkgdir/usr/share/doc/cf-cli/LICENSE"
+ install $srcdir/NOTICE "$pkgdir/usr/share/doc/cf-cli/NOTICE"
}
+