summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAbrarSyed2015-07-25 14:16:45 -0500
committerAbrarSyed2015-07-25 14:16:45 -0500
commitfb9d2e522066584f781320b6f54a97a1501ef270 (patch)
treef0e098037e0f6f8dd739ce180de24c1884fb2d7d
downloadaur-fb9d2e522066584f781320b6f54a97a1501ef270.tar.gz
initial commit for version 6.12.2
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af9e2f40f34a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = cloudfoundry-cli
+ pkgdesc = The official command line client for Cloud Foundry
+ pkgver = 6.12.2
+ pkgrel = 1
+ url = https://github.com/cloudfoundry/cli
+ arch = i686
+ arch = x86_64
+ license = Apache
+ options = !emptydirs
+ options = !strip
+ source = license.txt::https://raw.githubusercontent.com/cloudfoundry/cli/v6.12.2/LICENSE
+ md5sums = cbb45add8fd7cba6cdf4dcdad47bacc9
+ sha256sums = 1c57a832ebd8d56c3ed8480a9514a89bce25f35458a018e0ac30a5429c56cf8f
+ source_i686 = cf-cli-6.12.2-i686.tar.gz::https://cli.run.pivotal.io/stable?release=linux32-binary&version=6.12.2&source=github-rel
+ md5sums_i686 = e7fc3767977900bb11c301b33827690a
+ sha256sums_i686 = 474af7f0df79069d0beddfab1cc3503672b3ea5d12c20fd7cc780ec6d3fa6067
+ source_x86_64 = cf-cli-6.12.2-amd64.tar.gz::https://cli.run.pivotal.io/stable?release=linux64-binary&version=6.12.2&source=github-rel
+ md5sums_x86_64 = 9182661e3518a3c0ac19f247dd01a23b
+ sha256sums_x86_64 = 64180899f0962f2f0ad58d46c0f522fe2d0deec5024bbbc5ce2c765f8bc03de7
+
+pkgname = cloudfoundry-cli
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a980af00afe5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..564b92decd7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: AbrarSyed <sacabrarsyed g-mail>
+pkgname=cloudfoundry-cli
+pkgver=6.12.2
+pkgrel=1
+pkgdesc="The official command line client for Cloud Foundry"
+arch=('i686' 'x86_64')
+url="https://github.com/cloudfoundry/cli"
+license=('Apache')
+provides=()
+options=('!emptydirs' '!strip')
+
+source=("license.txt::https://raw.githubusercontent.com/cloudfoundry/cli/v${pkgver}/LICENSE")
+source_i686=("cf-cli-${pkgver}-i686.tar.gz::https://cli.run.pivotal.io/stable?release=linux32-binary&version=${pkgver}&source=github-rel")
+source_x86_64=("cf-cli-${pkgver}-amd64.tar.gz::https://cli.run.pivotal.io/stable?release=linux64-binary&version=${pkgver}&source=github-rel")
+
+md5sums=('cbb45add8fd7cba6cdf4dcdad47bacc9')
+md5sums_i686=('e7fc3767977900bb11c301b33827690a')
+md5sums_x86_64=('9182661e3518a3c0ac19f247dd01a23b')
+sha256sums=('1c57a832ebd8d56c3ed8480a9514a89bce25f35458a018e0ac30a5429c56cf8f')
+sha256sums_i686=('474af7f0df79069d0beddfab1cc3503672b3ea5d12c20fd7cc780ec6d3fa6067')
+sha256sums_x86_64=('64180899f0962f2f0ad58d46c0f522fe2d0deec5024bbbc5ce2c765f8bc03de7')
+
+package() {
+ # copy binary
+ mkdir -p "$pkgdir/usr/bin"
+ install $srcdir/cf "$pkgdir/usr/bin"
+
+ #copy license
+ mkdir -p "$pkgdir/usr/share/doc/cf-cli"
+ install license.txt "$pkgdir/usr/share/doc/cf-cli/copyright"
+}