summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Brodbeck2018-01-25 14:09:57 +0100
committerMartin Brodbeck2018-01-25 14:09:57 +0100
commit8271cf1683720dff212d2d7eaadfa10ad5cbbcb3 (patch)
tree84f6e2aacb544732c2d9a55e8cd1dcf5a610a6b0
downloadaur-8271cf1683720dff212d2d7eaadfa10ad5cbbcb3.tar.gz
Initial commit.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c6d9ad61197
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cloudshell2-fan
+ pkgdesc = scipt and systemd service for CloudShell2 to turn fan on/off
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://www.rustysoft.de/?02_cloudshell2-fan
+ arch = armv7h
+ license = GPL3
+ depends = i2c-tools
+ depends = python
+ depends = python-systemd
+ source = https://github.com/beedaddy/cloudshell2-fan/archive/v1.1.1.tar.gz
+ sha256sums = f3236fdffcf519f3529c018541b4fb5b8847a62dffb8a0a3e9e2778bb3e9c0f7
+
+pkgname = cloudshell2-fan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fdede00bf053
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Martin Brodbeck <martin at brodbeck-online dot de>
+pkgname=cloudshell2-fan
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="scipt and systemd service for CloudShell2 to turn fan on/off"
+arch=('armv7h')
+url="https://www.rustysoft.de/?02_cloudshell2-fan"
+license=('GPL3')
+depends=('i2c-tools' 'python' 'python-systemd')
+source=(https://github.com/beedaddy/$pkgname/archive/v$pkgver.tar.gz)
+sha256sums=('f3236fdffcf519f3529c018541b4fb5b8847a62dffb8a0a3e9e2778bb3e9c0f7')
+
+package() {
+ cd $pkgname-$pkgver
+ install -D -m755 "cloudshell2-fan.py" "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m644 "cloudshell2-fan.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
+}