summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkleintux2022-08-29 22:19:10 +0200
committerkleintux2022-08-29 22:19:10 +0200
commit5ba6dc7576040d5ce9609094e8bdbe4152f94f60 (patch)
tree2f3a78b9d3cf3fce09673fe8382f611909617c1f
downloadaur-5ba6dc7576040d5ce9609094e8bdbe4152f94f60.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b2a4b02701f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = clp
+ pkgdesc = writes input files to stdout with syntax highlighting
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://git.sr.ht/~eskin/clp
+ arch = x86_64
+ arch = aarch64
+ license = custom
+ depends = luajit
+ depends = lua-lpeg
+ conflicts = clp-git
+ source = clp-0.2.0.tar.gz::https://git.sr.ht/~eskin/clp/archive/v0.2.0.tar.gz
+ sha256sums = fd2c44847b7746351bf9193040a06014c7c494010ffd034c42fdd66afb49a62e
+
+pkgname = clp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..240e5cffc26c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: kleintux <reg-archlinux AT klein DOT tuxli DOT ch>
+
+pkgname=clp
+pkgver=0.2.0
+pkgrel=1
+pkgdesc='writes input files to stdout with syntax highlighting'
+arch=('x86_64' 'aarch64')
+url="https://git.sr.ht/~eskin/clp"
+license=('custom')
+depends=('luajit' 'lua-lpeg')
+source=("${pkgname}-${pkgver}.tar.gz::https://git.sr.ht/~eskin/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('fd2c44847b7746351bf9193040a06014c7c494010ffd034c42fdd66afb49a62e')
+conflicts=("${pkgname}-git")
+
+build() {
+ cd "${pkgname}-v${pkgver}"
+ ./configure
+ make
+}
+
+package() {
+ cd "${pkgname}-v${pkgver}"
+ make MANPREFIX=/usr/share/man DESTDIR="${pkgdir}" PREFIX='/usr' install
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}