summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLinus Östberg2015-07-09 14:31:44 +0200
committerLinus Östberg2015-07-09 14:31:44 +0200
commit01eeab3e0ec36c1e1c78c8799cebcc4a0016b9f3 (patch)
tree99e2579fb26384b65c0ff79032a5c7f714e81a41
downloadaur-01eeab3e0ec36c1e1c78c8799cebcc4a0016b9f3.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1468b83b2ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = clustal-omega
+ pkgdesc = Protein sequence alignment program
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = http://www.clustal.org/omega/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = glib2
+ depends = argtable
+ options = libtool
+ options = staticlibs
+ source = http://www.clustal.org/omega/clustal-omega-1.2.1.tar.gz
+ sha1sums = 50f67eb3244c25c9380e7afef0e157161535121b
+
+pkgname = clustal-omega
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69cf97a75641
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: talavis <aur at talavis eu>
+# Contributor: Kevin Dodd <jesin00 at gmail dot com>
+
+pkgname=clustal-omega
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="Protein sequence alignment program"
+arch=('i686' 'x86_64')
+url="http://www.clustal.org/omega/"
+license=('LGPL')
+depends=('glib2' 'argtable')
+source=("http://www.clustal.org/omega/${pkgname}-${pkgver}.tar.gz")
+options=(libtool staticlibs)
+sha1sums=('50f67eb3244c25c9380e7afef0e157161535121b')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr || return
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}