summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Teichroeb2015-06-08 16:31:50 -0700
committerJoel Teichroeb2015-06-08 16:31:50 -0700
commita2606ce941fbda6413855e1935abc47abbcf37a3 (patch)
tree1ef15c6b4c0a79671bc4a18ba6c3441562085fd6
downloadaur-a2606ce941fbda6413855e1935abc47abbcf37a3.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD36
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..55f1a09473db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = clutter-git
+ pkgdesc = A GObject based library for creating fast, visually rich graphical user interfaces
+ pkgver = 1.22.0.r38.g896e43c
+ pkgrel = 1
+ url = http://clutter-project.org/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = cogl
+ depends = mesa
+ depends = json-glib
+ depends = atk
+ depends = libxi
+ depends = gtk-doc
+ depends = libinput
+ depends = gobject-introspection
+ depends = libxkbcommon
+ provides = clutter=1.22.0.r38.g896e43c
+ conflicts = clutter
+ source = git://git.gnome.org/clutter
+ md5sums = SKIP
+
+pkgname = clutter-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18dc96fbb066
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Joel Teichroeb <joel@teichroeb.net>
+# Contributor: atie H. <atie.at.matrix@gmail.com>
+# Contributor: alesko <askondro@gmail.com>
+
+pkgname=clutter-git
+pkgver=1.22.0.r38.g896e43c
+pkgrel=1
+pkgdesc='A GObject based library for creating fast, visually rich graphical user interfaces'
+arch=('i686' 'x86_64')
+url='http://clutter-project.org/'
+license=('LGPL')
+depends=('cogl' 'mesa' 'json-glib' 'atk' 'libxi' 'gtk-doc' 'libinput' 'gobject-introspection' 'libxkbcommon')
+makedepends=('git')
+provides=("clutter=${pkgver}")
+conflicts=('clutter')
+source=('git://git.gnome.org/clutter')
+md5sums=('SKIP')
+
+pkgver() {
+ cd clutter
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd clutter
+
+ ./autogen.sh --prefix=/usr --enable-introspection \
+ --enable-wayland-backend --enable-egl-backend --enable-evdev-input \
+ --enable-wayland-compositor
+ make
+}
+
+package() {
+ cd clutter
+ make DESTDIR=$pkgdir install
+}