summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen James2016-08-18 18:38:46 -0500
committerBen James2016-08-18 18:38:46 -0500
commit66b4ff1f1776b2f76db07057cd8f65de55005af8 (patch)
tree9d21b41026a1bb2110ec3a94b466751ad47f380c
parent9df8065568d461a953eff95063f2e73a25731854 (diff)
downloadaur-66b4ff1f1776b2f76db07057cd8f65de55005af8.tar.gz
added missing extensions
The lisp files in the source repository's 'extensions' folder were not installed in the old PKGBUILD.
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e43be7e5352..a141f195da7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Benjamin James <benjamin-james@utulsa.edu>
+# Maintainer: Benjamin James <bjames@openmailbox.org>
pkgname=clx-git
_clname=clx
-pkgver=r178.0a3bea0
+pkgver=r248.9b210e8
pkgrel=2
arch=('i686' 'x86_64')
pkgdesc="An X11 client for Common Lisp"
@@ -14,7 +14,7 @@ depends=('xorg-server' 'sbcl')
makedepends=('git' 'texinfo')
install=clx.install
source=(${pkgname}::git+https://github.com/sharplispers/clx.git
- README.licensing)
+ README.licensing)
md5sums=('SKIP'
'SKIP')
@@ -35,6 +35,8 @@ package() {
install -d ${pkgdir}/usr/share/common-lisp/source/${_clname}
install -m 644 -t ${pkgdir}/usr/share/common-lisp/source/${_clname} *.lisp
+ install -d ${pkgdir}/usr/share/common-lisp/source/${_clname}/extensions
+ install -m 644 -t ${pkgdir}/usr/share/common-lisp/source/${_clname}/extensions extensions/*.lisp
install -m 644 -t ${pkgdir}/usr/share/common-lisp/source/${_clname} ${_clname}.asd
install -d ${pkgdir}/usr/share/common-lisp/source/${_clname}/debug
install -m 644 -t ${pkgdir}/usr/share/common-lisp/source/${_clname}/debug debug/*.lisp