summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortrizen2015-06-17 13:33:40 +0300
committertrizen2015-06-17 13:33:40 +0300
commit470b7b2a9c65ce3ebb79723d884c6d342e0afaae (patch)
treeb093b80ba6e049ca29ab9b925e3d897940c3a9dd
downloadaur-470b7b2a9c65ce3ebb79723d884c6d342e0afaae.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
-rw-r--r--readme.install8
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..959d15ce7ba8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = clyrics
+ pkgdesc = An extensible lyrics fetcher, with daemon support for cmus and mocp.
+ pkgver = 0.04
+ pkgrel = 1
+ url = http://github.com/trizen/clyrics
+ install = readme.install
+ arch = any
+ license = GPLv3
+ depends = perl-www-mechanize
+ depends = perl-io-html
+ depends = perl-lwp-protocol-https
+ optdepends = moc: daemon support for moc player
+ optdepends = cmus: daemon support for cmus player
+ source = https://github.com/trizen/clyrics/archive/0.04.tar.gz
+ sha256sums = a878beccbbe947942c5df8bd2a8afb704756e82ab61a357816cb143ef12c77b0
+
+pkgname = clyrics
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c24d49654d7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Trizen <echo dHJpemVueEBnbWFpbC5jb20K | base64 -d>
+
+pkgname=clyrics
+pkgver=0.04
+pkgrel=1
+
+pkgdesc="An extensible lyrics fetcher, with daemon support for cmus and mocp."
+url="http://github.com/trizen/clyrics"
+
+arch=('any')
+license=('GPLv3')
+
+depends=('perl-www-mechanize' 'perl-io-html' 'perl-lwp-protocol-https')
+optdepends=('moc: daemon support for moc player'
+ 'cmus: daemon support for cmus player')
+
+source="https://github.com/trizen/${pkgname}/archive/${pkgver}.tar.gz"
+sha256sums=('a878beccbbe947942c5df8bd2a8afb704756e82ab61a357816cb143ef12c77b0')
+install='readme.install'
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+
+ cd plugins
+ for i in *
+ do
+ install -Dm644 "$i" "$pkgdir/usr/share/$pkgname/$i"
+ done
+
+ #cd '..'
+ #install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
diff --git a/readme.install b/readme.install
new file mode 100644
index 000000000000..f17b15e74e5f
--- /dev/null
+++ b/readme.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo -e "\n** Link or copy the plugin files in your: ~/.config/clyrics"
+ echo -e "** They can be found in: /usr/share/clyrics\n"
+}
+
+post_upgrade() {
+ post_install
+}