summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClément Bénier2019-07-31 17:14:01 +0200
committerClément Bénier2019-07-31 17:14:01 +0200
commit53f2a1710edb5b9a477d400ce095693754f008bb (patch)
treece7cce6cfda8973b0c5a4fec8fdb543e9b7883aa
downloadaur-cmake-afb-template-git.tar.gz
cmake-afb-template: initial commit
Signed-off-by: Clément Bénier <clement.benier@iot.bzh>
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD45
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..936f21241020
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cmake-afb-template-git
+ pkgdesc = This is a CMake module made to ease development of binding and application framework binder apps.
+ pkgver = 8.0.0
+ pkgrel = 1
+ url = https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/cmake-apps-module
+ arch = any
+ license = Apache-2.0
+ makedepends = cmake
+ makedepends = gcc
+ provides = cmake-afb-template
+ conflicts = cmake-afb-template
+ source = cmake-afb-template::git+https://gerrit.automotivelinux.org/gerrit/src/cmake-apps-module
+ md5sums = SKIP
+
+pkgname = cmake-afb-template-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3859a4c52f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Clément Bénier <clement@benier.bzh>
+pkgname=cmake-afb-template-git
+pkgver=8.0.0
+pkgrel=1
+pkgdesc="
+This is a CMake module made to ease development of binding and application
+framework binder apps."
+arch=('any')
+url="https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/cmake-apps-module"
+license=('Apache-2.0')
+groups=()
+depends=()
+makedepends=('cmake' 'gcc')
+checkdepends=()
+optdepends=()
+provides=('cmake-afb-template')
+conflicts=('cmake-afb-template')
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("${pkgname%-git}::git+https://gerrit.automotivelinux.org/gerrit/src/cmake-apps-module")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git tag | grep -E "^[0-9]" | sort -r | head -1
+}
+
+build() {
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build"
+
+ cmake "$srcdir/${pkgname%-git}" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+}
+
+package() {
+ cd "$srcdir/build"
+ make DESTDIR="$pkgdir/" install
+ install -D -m644 "${srcdir}/${pkgname%-git}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}