summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-01-31 13:43:35 +0100
committerMartchus2020-01-31 13:43:35 +0100
commit096f008e4925f2d987e3f5d59677de637979ae09 (patch)
treea92bb113f36eac7a653b338f2deb307af49ce470
parent5e21a91ec667b509ac6a27f5db73c645307279e4 (diff)
downloadaur-096f008e4925f2d987e3f5d59677de637979ae09.tar.gz
Update to 0.6.8
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 20 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e7cde0b5be9..dedc81d82d7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = cmake-format
pkgdesc = Source code formatter for CMake listfiles
- pkgver = 0.6.7
- pkgrel = 2
+ pkgver = 0.6.8
+ pkgrel = 1
url = https://github.com/cheshirekow/cmake_format
arch = any
license = GPL3
checkdepends = cmake
- checkdepends = python-pgpy
depends = python-setuptools
- depends = python-yaml>=5.3
- depends = python-jinja>=2.10.3
- depends = python-six>=1.14.0
- source = cmake-format-0.6.7.tar.gz::https://github.com/cheshirekow/cmake_format/archive/v0.6.7.tar.gz
- sha512sums = 1d1a637ea5e91540030c3b28606bc211d8d6951d96d84b0318c5a9261be06dd81c929827eae3090aa75004be70d059fe6f5b580854ea093c1aebe19b087bb734
+ depends = python-six>=1.13.0
+ optdepends = python-yaml>=5.3
+ optdepends = python-jinja>=2.10.3
+ source = cmake-format-0.6.8.tar.gz::https://github.com/cheshirekow/cmake_format/archive/v0.6.8.tar.gz
+ sha512sums = 34c27dddef07704347943cb455462d2ea6d848acfc1c34e9cb16ce272e1fa0246414a864cd5d3f289158a20e277748b4f03d56961e9175948c954623d5750e41
pkgname = cmake-format
diff --git a/PKGBUILD b/PKGBUILD
index 3e71bba08998..9d72252421bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,30 @@
# you also find the URL of a binary repository.
pkgname=cmake-format
-pkgver=0.6.7
-pkgrel=2
+pkgver=0.6.8
+pkgrel=1
pkgdesc='Source code formatter for CMake listfiles'
arch=('any')
url='https://github.com/cheshirekow/cmake_format'
license=('GPL3')
-depends=('python-setuptools' 'python-yaml>=5.3' 'python-jinja>=2.10.3' 'python-six>=1.14.0')
-checkdepends=('cmake' 'python-pgpy')
+depends=('python-setuptools' 'python-six>=1.13.0')
+optdepends=('python-yaml>=5.3' 'python-jinja>=2.10.3')
+checkdepends=('cmake')
source=("$pkgname-$pkgver.tar.gz::https://github.com/cheshirekow/cmake_format/archive/v${pkgver}.tar.gz")
-sha512sums=('1d1a637ea5e91540030c3b28606bc211d8d6951d96d84b0318c5a9261be06dd81c929827eae3090aa75004be70d059fe6f5b580854ea093c1aebe19b087bb734')
+sha512sums=('34c27dddef07704347943cb455462d2ea6d848acfc1c34e9cb16ce272e1fa0246414a864cd5d3f289158a20e277748b4f03d56961e9175948c954623d5750e41')
check() {
mkdir "$srcdir/check"
cd "$srcdir/check"
export CTEST_OUTPUT_ON_FAILURE=1
cmake "$srcdir/cmake_format-$pkgver"
- ctest --exclude-regex cmake_format-command-db-test
+ ctest --exclude-regex 'verify-export|cmake_format-command-db-test|cmake_format-validate-database|cmake_format-doc-verify-README\.rst'
+
+ # note: Excluding the tests cmake_format-validate-database (would require gpg2 and
+ # python-pgpy and currently fails because an internet connection is required) and
+ # cmake_format-command-db-test (fails if CMake version doesn't match the version
+ # in upstream's CI). Also exluding verify-export and cmake_format-doc-verify-README.rst
+ # which seem specific to how upstream manages their Git repo.
}
package() {