summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-01-24 15:57:30 +0100
committerMartchus2020-01-24 15:57:30 +0100
commit5e21a91ec667b509ac6a27f5db73c645307279e4 (patch)
tree669985879900f9dd7bb9142e44adfbe5a87a06e5
parentcb4b7f65825d604eddc35add8a2ee24287a5b571 (diff)
downloadaur-5e21a91ec667b509ac6a27f5db73c645307279e4.tar.gz
Run tests, update dependencies
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 17 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e4e79d91b59..7e7cde0b5be9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = cmake-format
pkgdesc = Source code formatter for CMake listfiles
pkgver = 0.6.7
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/cheshirekow/cmake_format
arch = any
license = GPL3
+ checkdepends = cmake
+ checkdepends = python-pgpy
depends = python-setuptools
- depends = python-yaml
- depends = python-jinja
+ depends = python-yaml>=5.3
+ depends = python-jinja>=2.10.3
+ depends = python-six>=1.14.0
source = cmake-format-0.6.7.tar.gz::https://github.com/cheshirekow/cmake_format/archive/v0.6.7.tar.gz
sha512sums = 1d1a637ea5e91540030c3b28606bc211d8d6951d96d84b0318c5a9261be06dd81c929827eae3090aa75004be70d059fe6f5b580854ea093c1aebe19b087bb734
diff --git a/PKGBUILD b/PKGBUILD
index ea6289f975ba..3e71bba08998 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,24 @@
pkgname=cmake-format
pkgver=0.6.7
-pkgrel=1
+pkgrel=2
pkgdesc='Source code formatter for CMake listfiles'
arch=('any')
url='https://github.com/cheshirekow/cmake_format'
license=('GPL3')
-depends=('python-setuptools' 'python-yaml' 'python-jinja')
+depends=('python-setuptools' 'python-yaml>=5.3' 'python-jinja>=2.10.3' 'python-six>=1.14.0')
+checkdepends=('cmake' 'python-pgpy')
source=("$pkgname-$pkgver.tar.gz::https://github.com/cheshirekow/cmake_format/archive/v${pkgver}.tar.gz")
sha512sums=('1d1a637ea5e91540030c3b28606bc211d8d6951d96d84b0318c5a9261be06dd81c929827eae3090aa75004be70d059fe6f5b580854ea093c1aebe19b087bb734')
+check() {
+ mkdir "$srcdir/check"
+ cd "$srcdir/check"
+ export CTEST_OUTPUT_ON_FAILURE=1
+ cmake "$srcdir/cmake_format-$pkgver"
+ ctest --exclude-regex cmake_format-command-db-test
+}
+
package() {
cd "$srcdir/cmake_format-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1