summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2020-08-19 11:48:17 +0200
committerMartchus2020-08-19 11:48:17 +0200
commitcaeb5ec087e0b9c98bb06ce6e34d1bdf7331c725 (patch)
treecb16ddd21e56c960feef6a5fc01442d70dd8763a
parent44336481fb06e5482a6e87e0f33481c8908d2ed1 (diff)
downloadaur-caeb5ec087e0b9c98bb06ce6e34d1bdf7331c725.tar.gz
Update to 0.6.12
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bbc5b7aeed3..cba3f8a8d1b7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cmake-format
pkgdesc = Source code formatter for CMake listfiles
- pkgver = 0.6.11
+ pkgver = 0.6.12
pkgrel = 1
url = https://github.com/cheshirekow/cmake_format
arch = any
@@ -11,8 +11,8 @@ pkgbase = cmake-format
optdepends = python-yaml>=5.3
optdepends = python-jinja>=2.10.3
optdepends = python-argcomplete: automatic shell completion
- source = cmake-format-0.6.11.tar.gz::https://github.com/cheshirekow/cmake_format/archive/v0.6.11.tar.gz
- sha512sums = 52b6752d2b62097df790f432ecfb2e3d196950ad49548fa3c68a329f16f9e2d3db2741debe2b3f913894857805b60b1b460a939fd1b34a58efa738175839dea8
+ source = cmake-format-0.6.12.tar.gz::https://github.com/cheshirekow/cmake_format/archive/v0.6.12.tar.gz
+ sha512sums = e54d54ba592875ad2d8683a3be7dce10c8ddbf6ef39ac127510de8de3598763179768594d0f30ab98df87a19a989920916dcf9d759abff59854d738227a7644e
pkgname = cmake-format
diff --git a/PKGBUILD b/PKGBUILD
index 1ce7a020edba..a41d74aef27a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# you also find the URL of a binary repository.
pkgname=cmake-format
-pkgver=0.6.11
+pkgver=0.6.12
pkgrel=1
pkgdesc='Source code formatter for CMake listfiles'
arch=('any')
@@ -14,19 +14,19 @@ depends=('python-setuptools' 'python-six>=1.13.0')
optdepends=('python-yaml>=5.3' 'python-jinja>=2.10.3' 'python-argcomplete: automatic shell completion')
checkdepends=('cmake')
source=("$pkgname-$pkgver.tar.gz::https://github.com/cheshirekow/cmake_format/archive/v${pkgver}.tar.gz")
-sha512sums=('52b6752d2b62097df790f432ecfb2e3d196950ad49548fa3c68a329f16f9e2d3db2741debe2b3f913894857805b60b1b460a939fd1b34a58efa738175839dea8')
+sha512sums=('e54d54ba592875ad2d8683a3be7dce10c8ddbf6ef39ac127510de8de3598763179768594d0f30ab98df87a19a989920916dcf9d759abff59854d738227a7644e')
check() {
mkdir "$srcdir/check"
cd "$srcdir/check"
export CTEST_OUTPUT_ON_FAILURE=1
cmake "$srcdir/cmake_format-$pkgver"
- ctest --exclude-regex 'verify-export|cmake_format-command-db-test|cmake_format-validate-database|cmake_format-doc-verify-README\.rst'
+ ctest --exclude-regex 'verify-export|cmakelang-command-db-test|cmakelang-validate-database|cmakelang-doc-verify-README\.rst'
- # note: Excluding the tests cmake_format-validate-database (would require gpg2 and
+ # note: Excluding the tests cmakelang-validate-database (would require gpg2 and
# python-pgpy and currently fails because an internet connection is required) and
- # cmake_format-command-db-test (fails if CMake version doesn't match the version
- # in upstream's CI). Also exluding verify-export and cmake_format-doc-verify-README.rst
+ # cmakelang-command-db-test (fails if CMake version doesn't match the version
+ # in upstream's CI). Also exluding verify-export and cmakelang-doc-verify-README.rst
# which seem specific to how upstream manages their Git repo.
}