summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormuio2022-04-23 20:58:03 +0000
committermuio2022-04-24 01:28:03 +0430
commit3e9d9d6ad0b221d4f72720fd5efd27ae4898cddb (patch)
treeaddd7dc141c81e4567477726ff31ed57eb46c2b3
parent58291a4678897d3788a7c5f7976905371594bd5e (diff)
downloadaur-3e9d9d6ad0b221d4f72720fd5efd27ae4898cddb.tar.gz
Add pkgver()
So I don't have to bump the version every time. Down-side is that .SRCINFO won't be updated and the user won't be notified for updates.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1ea6090b30b..470c26751548 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = cmake-init
pkgdesc = The missing CMake project initializer
- pkgver = 0.27.4
+ pkgver = 0.29.0
pkgrel = 1
url = https://github.com/friendlyanon/cmake-init
arch = any
license = GPL3
makedepends = python-pip
+ makedepends = jq
+ makedepends = curl
+ makedepends = sed
depends = python3
- source = https://files.pythonhosted.org/packages/py3/c/cmake-init/cmake_init-0.27.4-py3-none-any.whl
- sha256sums = bba839c34fb192e136ecdd5e1a4e77d5ec80c9e4858534722dcb579499dff39a
+ source = https://files.pythonhosted.org/packages/py3/c/cmake-init/cmake_init-0.29.0-py3-none-any.whl
+ sha256sums = SKIP
pkgname = cmake-init
diff --git a/PKGBUILD b/PKGBUILD
index 51cec10ae893..81d5e1e474d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,25 @@
pkgname=cmake-init
_name=${pkgname#python-}
-pkgver=0.27.4
+pkgver=0.29.0
pkgrel=1
pkgdesc="The missing CMake project initializer"
arch=('any')
url="https://github.com/friendlyanon/cmake-init"
license=('GPL3')
depends=('python3')
-makedepends=('python-pip')
+makedepends=('python-pip' 'jq' 'curl' 'sed')
source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/${_name//-/_}-$pkgver-py3-none-any.whl")
-sha256sums=('bba839c34fb192e136ecdd5e1a4e77d5ec80c9e4858534722dcb579499dff39a')
+sha256sums=('SKIP')
# build() {
# echo ''
# }
+pkgver() {
+ curl -sH "Accept: application/vnd.github.v3+json" https://api.github.com/repos/friendlyanon/cmake-init/tags | jq -r '.[0].name' | sed 's/v//;s/-/./;s/-/./'
+}
+
package() {
PIP_CONFIG_FILE=/dev/null pip install --no-warn-script-location --isolated --root="$pkgdir" --ignore-installed --no-deps "${_name//-/_}-$pkgver-py3-none-any.whl"