summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormuio2023-12-28 00:34:32 +0000
committermuio2023-12-27 19:34:32 -0500
commit45af636fabf4d368f5e161d3dd94556f1d700fc2 (patch)
treef5fb0dd25cb730db637d042a86e7ccf60afce645
parent899b8b45f0204e396200f2c168cce821cf281e8a (diff)
downloadaur-45af636fabf4d368f5e161d3dd94556f1d700fc2.tar.gz
Switch to .pyz releases from github repo
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 6 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d2141d3e1d8..787cd685eaa3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,9 +5,8 @@ pkgbase = cmake-init
url = https://github.com/friendlyanon/cmake-init
arch = any
license = GPL3
- makedepends = python-pip
depends = python3
- source = https://files.pythonhosted.org/packages/py3/c/cmake-init/cmake_init-0.39.0-py3-none-any.whl
- sha256sums = 9372a21ec799acd4032024cd0187b496dfd1e97deb226bc4618a74ce8f57cb5c
+ source = cmake-init-0.39.0.pyz::https://github.com/friendlyanon/cmake-init/releases/download/v0.39.0/cmake-init.pyz
+ sha256sums = 01d14c029a70e8a6f12b2b3d06c4551d53ad7e91c0a8a5e90905385dc55e3069
pkgname = cmake-init
diff --git a/PKGBUILD b/PKGBUILD
index 51744c789d5d..22e525b5a20e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,18 +9,14 @@ arch=('any')
url="https://github.com/friendlyanon/cmake-init"
license=('GPL3')
depends=('python3')
-makedepends=('python-pip')
-source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/${_name//-/_}-$pkgver-py3-none-any.whl")
-sha256sums=('d3802e9ca3dd2b6b85bb563514912ad138858652d22500e66db24d46d36f81ec')
+source=("cmake-init-${pkgver}.pyz::https://github.com/friendlyanon/cmake-init/releases/download/v${pkgver}/cmake-init.pyz")
+sha256sums=('01d14c029a70e8a6f12b2b3d06c4551d53ad7e91c0a8a5e90905385dc55e3069')
#pkgver() {
# curl -sH "Accept: application/vnd.github.v3+json" 'https://api.github.com/repos/friendlyanon/cmake-init/tags' | jq -r '.[0].name' | sed 's/v//;s/-/./;s/-/./'
#}
package() {
- PIP_CONFIG_FILE=/dev/null pip install --no-warn-script-location --isolated --root="$pkgdir" --ignore-installed --no-deps "${_name//-/_}-$pkgver-py3-none-any.whl"
-
- # cd "${pkgdir}/usr/lib/python3/site-packages/cmake_init_lib"
- COMPILE_DIR=$(find "${pkgdir}" -name cmake_init_lib -type d | head -n 1) # this is a shitty hack, please inform me of a better way to do this.
- [ ! -z "$COMPILE_DIR" ] && python -O -m compileall "${COMPILE_DIR}"
+ cd "$srcdir/$_pkgname"
+ install -D -m755 "cmake-init-${pkgver}.pyz" "${pkgdir}/usr/bin/cmake-init"
}