summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormuio2021-10-26 03:06:43 +0000
committermuio2021-10-26 06:36:43 +0330
commit70305a51e5aa25ee5401c213aec877ba85158406 (patch)
treeeac2f24a6dfcd3c62daf6e73a5e2f5dc35add227
parentcec74f2ba0a34a1a76fe7897eeae249b908ade67 (diff)
downloadaur-70305a51e5aa25ee5401c213aec877ba85158406.tar.gz
Bump version to 0.22.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b2a60abc934..d1dd0bb84bc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = cmake-init
pkgdesc = The missing CMake project initializer
- pkgver = 0.21.5
+ pkgver = 0.22.0
pkgrel = 1
url = https://github.com/friendlyanon/cmake-init
arch = any
license = GPL3
makedepends = python-pip
depends = python3
- source = https://files.pythonhosted.org/packages/py3/c/cmake-init/cmake_init-0.21.5-py3-none-any.whl
- sha256sums = 0e1b8036c142965c7a1aaa71f5602d3623f4f787960ce66d5fc9fff5bbdf2029
+ source = https://files.pythonhosted.org/packages/py3/c/cmake-init/cmake_init-0.22.0-py3-none-any.whl
+ sha256sums = b430bb3cdc6be70ede7ef3cf32072b5588773bfe3c7f7456fbce025538c46e5a
pkgname = cmake-init
diff --git a/PKGBUILD b/PKGBUILD
index 002bf95e10a2..cb7ad64f8ba7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=cmake-init
_name=${pkgname#python-}
-pkgver=0.21.5
+pkgver=0.22.0
pkgrel=1
pkgdesc="The missing CMake project initializer"
arch=('any')
@@ -11,7 +11,7 @@ license=('GPL3')
depends=('python3')
makedepends=('python-pip')
source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/${_name//-/_}-$pkgver-py3-none-any.whl")
-sha256sums=('0e1b8036c142965c7a1aaa71f5602d3623f4f787960ce66d5fc9fff5bbdf2029')
+sha256sums=('b430bb3cdc6be70ede7ef3cf32072b5588773bfe3c7f7456fbce025538c46e5a')
# build() {
# echo ''
@@ -19,5 +19,8 @@ sha256sums=('0e1b8036c142965c7a1aaa71f5602d3623f4f787960ce66d5fc9fff5bbdf2029')
package() {
PIP_CONFIG_FILE=/dev/null pip install --no-warn-script-location --isolated --root="$pkgdir" --ignore-installed --no-deps "${_name//-/_}-$pkgver-py3-none-any.whl"
- python -O -m compileall "${pkgdir}/usr/lib/python3.9/site-packages/cmake_init_lib"
+
+ # cd "${pkgdir}/usr/lib/python3/site-packages/cmake_init_lib"
+ COMPILE_DIR=$(find "${pkgdir}" -name cmake_init_lib -type d | head -n 1) # this is a shitty hack, please inform me of a better way to do this.
+ [ ! -z "$COMPILE_DIR" ] && python -O -m compileall "${COMPILE_DIR}"
}