summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormuio2022-07-07 08:33:00 +0000
committermuio2022-07-07 13:03:00 +0430
commitdd208f9a4b9d77f42a05ab4466868b9c81e47842 (patch)
treeee28515c9216b004a8f3c42b95f0d5d8b6d13413
parentf1e103b66d21872fe5345b999ba627f71af7fa75 (diff)
downloadaur-dd208f9a4b9d77f42a05ab4466868b9c81e47842.tar.gz
Bump to 0.31.2
Also, get rid of automatic pkgver updating since we now have camke-init-git in AUR.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD16
2 files changed, 9 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 369150c5a268..0163ce511dd6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
pkgbase = cmake-init
pkgdesc = The missing CMake project initializer
- pkgver = 0.30.1
+ pkgver = 0.31.2
pkgrel = 1
url = https://github.com/friendlyanon/cmake-init
arch = any
license = GPL3
makedepends = python-pip
- makedepends = jq
- makedepends = curl
- makedepends = sed
depends = python3
- source = https://files.pythonhosted.org/packages/py3/c/cmake-init/cmake_init-0.30.1-py3-none-any.whl
- sha256sums = SKIP
+ source = https://files.pythonhosted.org/packages/py3/c/cmake-init/cmake_init-0.31.2-py3-none-any.whl
+ sha256sums = 3611b728c0e74e91f3ad0c78531dffdee35ab91283afb187e61558fb66d3fcf3
pkgname = cmake-init
diff --git a/PKGBUILD b/PKGBUILD
index 68ffba078fe5..69f72b3af372 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,20 @@
pkgname=cmake-init
_name=${pkgname#python-}
-pkgver=0.30.1
+pkgver=0.31.2
pkgrel=1
pkgdesc="The missing CMake project initializer"
arch=('any')
url="https://github.com/friendlyanon/cmake-init"
license=('GPL3')
depends=('python3')
-makedepends=('python-pip' 'jq' 'curl' 'sed')
+makedepends=('python-pip')
source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/${_name//-/_}-$pkgver-py3-none-any.whl")
-sha256sums=('SKIP')
+sha256sums=('3611b728c0e74e91f3ad0c78531dffdee35ab91283afb187e61558fb66d3fcf3')
-# build() {
-# echo ''
-# }
-
-pkgver() {
- curl -sH "Accept: application/vnd.github.v3+json" 'https://api.github.com/repos/friendlyanon/cmake-init/tags' | jq -r '.[0].name' | sed 's/v//;s/-/./;s/-/./'
-}
+#pkgver() {
+# curl -sH "Accept: application/vnd.github.v3+json" 'https://api.github.com/repos/friendlyanon/cmake-init/tags' | jq -r '.[0].name' | sed 's/v//;s/-/./;s/-/./'
+#}
package() {
PIP_CONFIG_FILE=/dev/null pip install --no-warn-script-location --isolated --root="$pkgdir" --ignore-installed --no-deps "${_name//-/_}-$pkgver-py3-none-any.whl"