summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2018-01-05 12:58:46 +0100
committerPhilipp A2018-01-05 12:58:56 +0100
commitd877f6750b81afb5e936bf90ac9ca816ac32ee47 (patch)
tree47e7d14806fc2b034a38b3a5dfa6104054e3b8b9
downloadaur-d877f6750b81afb5e936bf90ac9ca816ac32ee47.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD17
3 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4fbf096ca385
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = cmake-modules-libr
+ pkgdesc = CMake module for libR
+ pkgver = 1.1.411
+ pkgrel = 1
+ url = https://github.com/rstudio/rstudio/blob/master/cmake/modules/FindLibR.cmake
+ arch = any
+ license = AGPL
+ depends = cmake
+ source = FindLibR-1.1.411.cmake::https://github.com/rstudio/rstudio/raw/v1.1.411/cmake/modules/FindLibR.cmake
+ md5sums = 7c8b013c5bd5574c1e56a2582c1d984b
+
+pkgname = cmake-modules-libr
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9380020975c2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.pkg.tar.xz
+/*.cmake
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d4772cb9ae7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+
+pkgname=cmake-modules-libr
+pkgver=1.1.411
+pkgrel=1
+pkgdesc="CMake module for libR"
+arch=(any)
+url="https://github.com/rstudio/rstudio/blob/master/cmake/modules/FindLibR.cmake"
+license=('AGPL')
+depends=(cmake)
+source=("FindLibR-$pkgver.cmake::https://github.com/rstudio/rstudio/raw/v$pkgver/cmake/modules/FindLibR.cmake")
+md5sums=('7c8b013c5bd5574c1e56a2582c1d984b')
+
+package() {
+ cmake_version="$(cmake --version | head -n1 | cut -d ' ' -f 3 | cut -d . -f 1-2)"
+ install -Dm644 "$srcdir/FindLibR-$pkgver.cmake" "$pkgdir/usr/share/cmake-$cmake_version/Modules/FindLibR.cmake"
+}