summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Schindler2015-06-20 13:35:34 +0200
committerFelix Schindler2015-06-20 13:39:44 +0200
commitfd8e331e47ec920f1b7f59308de364f8d89496d7 (patch)
tree67f568828d667121940cbb6b10514585ae941228
downloadaur-cmake2.tar.gz
add state of https://github.com/ftalbrecht/aur, rev. 84761b9
-rw-r--r--.SRCINFO26
-rw-r--r--FindPython-Interp-Libs-Search-for-Python-3.4.patch40
-rw-r--r--PKGBUILD61
-rw-r--r--cmake2.install12
-rw-r--r--findfreetype.patch26
5 files changed, 165 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4fd2ca5b1a5f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by makepkg 4.2.1
+# Sat Jun 20 11:38:33 UTC 2015
+pkgbase = cmake2
+ pkgdesc = A cross-platform open-source make system
+ pkgver = 2.8.12.2
+ pkgrel = 1
+ url = http://www.cmake.org/
+ install = cmake2.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = qt4
+ makedepends = emacs
+ depends = curl
+ depends = libarchive
+ depends = shared-mime-info
+ optdepends = qt4: cmake-gui
+ source = http://www.cmake.org/files/v2.8/cmake-2.8.12.2.tar.gz
+ source = findfreetype.patch
+ source = FindPython-Interp-Libs-Search-for-Python-3.4.patch
+ md5sums = 17c6513483d23590cbce6957ec6d1e66
+ md5sums = 90321de1d9d46cd8d6609d0509dbd7b0
+ md5sums = 5e036a37f9b0b3368b8cfcc5784d1514
+
+pkgname = cmake2
+
diff --git a/FindPython-Interp-Libs-Search-for-Python-3.4.patch b/FindPython-Interp-Libs-Search-for-Python-3.4.patch
new file mode 100644
index 000000000000..fee6b39bfa09
--- /dev/null
+++ b/FindPython-Interp-Libs-Search-for-Python-3.4.patch
@@ -0,0 +1,40 @@
+From ab6201ab647c13fee44c44822b8502e9848faaaf Mon Sep 17 00:00:00 2001
+From: Matt McCormick <matt.mccormick@kitware.com>
+Date: Wed, 5 Mar 2014 17:41:47 -0500
+Subject: [PATCH] FindPython{Interp,Libs}: Search for Python 3.4.
+
+Python 3.4.0rnc1 was released on 2014-02-20.
+---
+ Modules/FindPythonInterp.cmake | 2 +-
+ Modules/FindPythonLibs.cmake | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Modules/FindPythonInterp.cmake b/Modules/FindPythonInterp.cmake
+index 8da848c..e23a58b 100644
+--- a/Modules/FindPythonInterp.cmake
++++ b/Modules/FindPythonInterp.cmake
+@@ -47,7 +47,7 @@ unset(_Python_NAMES)
+
+ set(_PYTHON1_VERSIONS 1.6 1.5)
+ set(_PYTHON2_VERSIONS 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0)
+-set(_PYTHON3_VERSIONS 3.3 3.2 3.1 3.0)
++set(_PYTHON3_VERSIONS 3.4 3.3 3.2 3.1 3.0)
+
+ if(PythonInterp_FIND_VERSION)
+ if(PythonInterp_FIND_VERSION_COUNT GREATER 1)
+diff --git a/Modules/FindPythonLibs.cmake b/Modules/FindPythonLibs.cmake
+index 0749efc..1dbc967 100644
+--- a/Modules/FindPythonLibs.cmake
++++ b/Modules/FindPythonLibs.cmake
+@@ -51,7 +51,7 @@ CMAKE_FIND_FRAMEWORKS(Python)
+
+ set(_PYTHON1_VERSIONS 1.6 1.5)
+ set(_PYTHON2_VERSIONS 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0)
+-set(_PYTHON3_VERSIONS 3.3 3.2 3.1 3.0)
++set(_PYTHON3_VERSIONS 3.4 3.3 3.2 3.1 3.0)
+
+ if(PythonLibs_FIND_VERSION)
+ if(PythonLibs_FIND_VERSION_COUNT GREATER 1)
+--
+1.9.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..435a3dd07358
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Felix Schindler
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
+#
+# This PKGBUILD is maintained at https://github.com/ftalbrecht/aur
+# in the cmake2 branch
+
+_pkgname=cmake
+pkgname=${_pkgname}2
+pkgver=2.8.12.2
+pkgrel=1
+pkgdesc="A cross-platform open-source make system"
+arch=('i686' 'x86_64')
+url="http://www.cmake.org/"
+license=('custom')
+depends=('curl' 'libarchive' 'shared-mime-info')
+makedepends=('qt4' 'emacs')
+optdepends=('qt4: cmake-gui')
+install="${pkgname}.install"
+source=("http://www.cmake.org/files/v2.8/${_pkgname}-${pkgver}.tar.gz"
+ "findfreetype.patch"
+ "FindPython-Interp-Libs-Search-for-Python-3.4.patch")
+md5sums=('17c6513483d23590cbce6957ec6d1e66'
+ '90321de1d9d46cd8d6609d0509dbd7b0'
+ '5e036a37f9b0b3368b8cfcc5784d1514')
+
+build() {
+ cd ${_pkgname}-${pkgver}
+
+ patch -Np1 < ${srcdir}/findfreetype.patch
+ patch -Np1 < ${srcdir}/FindPython-Interp-Libs-Search-for-Python-3.4.patch
+
+ ./bootstrap --prefix=/opt/$pkgname \
+ --mandir=/share/man \
+ --docdir=/share/doc/cmake \
+ --system-libs \
+ --qt-gui \
+ --parallel=$(/usr/bin/getconf _NPROCESSORS_ONLN)
+ make
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+
+ vimpath="${pkgdir}/opt/$pkgname/share/vim/vimfiles"
+ install -Dm644 Docs/cmake-indent.vim "${vimpath}"/indent/cmake-indent.vim
+ install -Dm644 Docs/cmake-syntax.vim "${vimpath}"/syntax/cmake-syntax.vim
+
+ install -Dm644 Docs/cmake-mode.el \
+ "${pkgdir}"/opt/$pkgname/share/emacs/site-lisp/cmake-mode.el
+ emacs -batch -f batch-byte-compile "${pkgdir}"/opt/$pkgname/share/emacs/site-lisp/cmake-mode.el
+
+ install -Dm644 Copyright.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+
+ install -d "${pkgdir}"/usr/bin
+ for b in "${pkgdir}"/opt/$pkgname/bin/*; do
+ ln -s /opt/$pkgname/bin/$(basename $b) "${pkgdir}"/usr/bin/$(basename $b)-2
+ done
+}
diff --git a/cmake2.install b/cmake2.install
new file mode 100644
index 000000000000..55f6c843bd10
--- /dev/null
+++ b/cmake2.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-mime-database usr/share/mime &> /dev/null
+ [[ -x usr/bin/update-desktop-database ]] && update-desktop-database -q || true
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/findfreetype.patch b/findfreetype.patch
new file mode 100644
index 000000000000..454b591dd3f5
--- /dev/null
+++ b/findfreetype.patch
@@ -0,0 +1,26 @@
+diff --git a/Modules/FindFreetype.cmake b/Modules/FindFreetype.cmake
+index 179dc00..0f5a2b4 100644
+--- a/Modules/FindFreetype.cmake
++++ b/Modules/FindFreetype.cmake
+@@ -62,10 +62,10 @@ find_path(FREETYPE_INCLUDE_DIR_ft2build ft2build.h
+ ENV GTKMM_BASEPATH
+ [HKEY_CURRENT_USER\\SOFTWARE\\gtkmm\\2.4;Path]
+ [HKEY_LOCAL_MACHINE\\SOFTWARE\\gtkmm\\2.4;Path]
+- PATH_SUFFIXES include/freetype2 include
++ PATH_SUFFIXES include/freetype2 include/freetype include
+ )
+
+-find_path(FREETYPE_INCLUDE_DIR_freetype2 freetype/config/ftheader.h
++find_path(FREETYPE_INCLUDE_DIR_freetype2 config/ftheader.h
+ HINTS
+ ENV FREETYPE_DIR
+ PATHS
+@@ -76,7 +76,7 @@ find_path(FREETYPE_INCLUDE_DIR_freetype2 freetype/config/ftheader.h
+ ENV GTKMM_BASEPATH
+ [HKEY_CURRENT_USER\\SOFTWARE\\gtkmm\\2.4;Path]
+ [HKEY_LOCAL_MACHINE\\SOFTWARE\\gtkmm\\2.4;Path]
+- PATH_SUFFIXES include/freetype2 include
++ PATH_SUFFIXES include/freetype2 include/freetype include include/freetype2/freetype
+ )
+
+ find_library(FREETYPE_LIBRARY