summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2019-08-05 00:02:20 +0100
committerEric Engestrom2019-08-05 00:02:35 +0100
commit45f5667ad9111f0068c26017aa15d51eaa9642bd (patch)
treeb0d8b8fb09cc2548bb9d30aab1269c4c9fb6c795
parentc652d39f61d74202b06436f8a74fcdad3b68f10a (diff)
downloadaur-45f5667ad9111f0068c26017aa15d51eaa9642bd.tar.gz
make sure the version is always valid
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2d1246f412c2..bbd9a73e800b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,8 @@ pkgver() {
awk 'match($$0, /\$Version: [^$]* \$/) {
print substr($0, RSTART + 10, RLENGTH - 12);
exit found=1;
- } END { exit !found }' cmb.c
+ } END { exit !found }' cmb.c |
+ sed s/-/./g
}
build() {