summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortimcowchip2015-06-10 00:10:00 -0700
committertimcowchip2015-06-10 00:10:00 -0700
commitb1712ac7e37fab13c23cfed934eb80c43fb266bb (patch)
tree839b1d626fb29132072f6e9f8296c4584bb7b9cd
downloadaur-cmdiag.tar.gz
Initial import
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
-rw-r--r--cmdiag.cpp.patch10
4 files changed, 78 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..26629be665b9
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = cmdiag
+ pkgdesc = Docsis cable modem diagnostic
+ pkgver = 0.2
+ pkgrel = 1
+ url = http://cmdiag.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = net-snmp
+ provides = cmdiag=0.2
+ source = http://downloads.sourceforge.net/cmdiag/cmdiag-0.2.tar.gz
+ source = cmdiag.cpp.patch
+
+pkgname = cmdiag
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a668ca679c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cmdiag
+ pkgdesc = Docsis cable modem diagnostic
+ pkgver = 0.2
+ pkgrel = 1
+ url = http://cmdiag.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = net-snmp
+ provides = cmdiag=0.2
+ source = http://downloads.sourceforge.net/cmdiag/cmdiag-0.2.tar.gz
+ source = cmdiag.cpp.patch
+ md5sums = e1bde5ef9d1c0f976f4cfe0af990d4e8
+ md5sums = 0ea5b066687e07db5c8551f82c819301
+
+pkgname = cmdiag
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae187446b723
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: celsius <chris@opensuse.us>
+pkgname=cmdiag
+pkgver=0.2
+pkgrel=1
+pkgdesc="Docsis cable modem diagnostic"
+arch=('i686' 'x86_64')
+url="http://cmdiag.sourceforge.net/"
+license=('GPL')
+depends=('net-snmp')
+makedepends=()
+optdepends=()
+provides=("cmdiag=$pkgver")
+conflicts=()
+replaces=()
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz cmdiag.cpp.patch)
+md5sums=('e1bde5ef9d1c0f976f4cfe0af990d4e8' '0ea5b066687e07db5c8551f82c819301')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ patch --verbose -p0 < $srcdir/cmdiag.cpp.patch
+
+ sed -i 's|\PREFIX = /usr/sbin|\PREFIX = /usr/bin|' Makefile
+
+ sed -i 's|\install $(EXEC) $(PREFIX)|\ |' Makefile
+
+ make clean
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ mkdir -p $pkgdir/usr/bin
+ cp -a $pkgname $pkgdir/usr/bin/$pkgname
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/cmdiag.cpp.patch b/cmdiag.cpp.patch
new file mode 100644
index 000000000000..b0a0332da50d
--- /dev/null
+++ b/cmdiag.cpp.patch
@@ -0,0 +1,10 @@
+--- cmdiag.cpp.orig 2008-05-01 22:42:18.000000000 +0200
++++ cmdiag.cpp 2011-08-08 12:05:24.113372114 +0200
+@@ -13,6 +13,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>
++#include <string.h>
+ #include "bar.h"
+ #include "pbar.h"
+ #include "globals.h"