summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2012-12-03 08:41:29 -0800
committerMike Swanson2012-12-03 08:41:29 -0800
commit87c3cb19dcb3986267377460cd75be1c629f579c (patch)
tree1406f22336cd9094f067f71ebd326c043582fef8
downloadaur-87c3cb19dcb3986267377460cd75be1c629f579c.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD46
-rw-r--r--cmdpack.install12
4 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..449c4f4ce03b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cmdpack
+ pkgdesc = Collection of command line utilities, most for emulation or disk images (bin2iso, bincomp, brrrip, byteshuf, byteswap, cdpatch, ecm, fakecrc, hax65816, id3point, pecompat, rels, screamf, subfile, uips, usfv, vb2rip, wordadd, zerofill)
+ pkgver = 1.03
+ pkgrel = 2
+ url = http://www.neillcorlett.com/cmdpack/
+ install = cmdpack.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ provides = ecm
+ provides = unecm
+ source = http://www.neillcorlett.com/downloads/cmdpack-1.03-src.tar.gz
+ sha256sums = 56a806f075dded183e29e85c9cda2c4662644a310e6916aea688a7b26f4e0a6c
+
+pkgname = cmdpack
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..665307854be8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.pkg.tar*
+*.src.tar*
+*.gz
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..132786451caa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
+
+# The pkgdesc is really long and not particularly pleasing as a
+# result. These utilties aren't entirely related to each other, but
+# are distributed together. Suggestions are welcome to making the
+# pkgdesc suitably fit in 80 characters (the names of all the
+# utilities in it are primarily to aide in searching the AUR for
+# them.).
+
+pkgname=cmdpack
+pkgver=1.03
+pkgrel=2
+pkgdesc="Collection of command line utilities, most for emulation or disk images (bin2iso, bincomp, brrrip, byteshuf, byteswap, cdpatch, ecm, fakecrc, hax65816, id3point, pecompat, rels, screamf, subfile, uips, usfv, vb2rip, wordadd, zerofill)"
+arch=('i686' 'x86_64')
+url="http://www.neillcorlett.com/cmdpack/"
+license=('GPL3')
+provides=('ecm' 'unecm')
+install=cmdpack.install
+source=("http://www.neillcorlett.com/downloads/${pkgname}-${pkgver}-src.tar.gz")
+sha256sums=('56a806f075dded183e29e85c9cda2c4662644a310e6916aea688a7b26f4e0a6c')
+
+_utilties=('bin2iso' 'bincomp' 'brrrip' 'byteshuf' 'byteswap'
+ 'cdpatch' 'ecm' 'fakecrc' 'hax65816' 'id3point' 'pecompat' 'rels'
+ 'screamf' 'subfile' 'uips' 'usfv' 'vb2rip' 'wordadd' 'zerofill')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}-src/src/
+
+ for elem in ${_utilties[@]}
+ do
+ gcc $CFLAGS $elem.c -o $elem
+ done
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}-src/src/
+
+ for elem in ${_utilties[@]}
+ do
+ install -Dm755 $elem ${pkgdir}/usr/bin/cmdpack/$elem
+ done
+
+ ln ${pkgdir}/usr/bin/cmdpack/ecm ${pkgdir}/usr/bin/cmdpack/unecm
+
+ install -Dm644 ../doc/cmdpack.txt ${pkgdir}/usr/share/doc/cmdpack/cmdpack.txt
+}
diff --git a/cmdpack.install b/cmdpack.install
new file mode 100644
index 000000000000..35099911e73d
--- /dev/null
+++ b/cmdpack.install
@@ -0,0 +1,12 @@
+post_install() {
+ cat <<EOF
+Due to conflicts with some of the generic-ish binary names in this
+package with core, extra, and community repository packages, they have
+now been all placed under /usr/bin/cmdpack, which you may add to your
+\$PATH for convenience.
+EOF
+}
+
+post_upgrade() {
+ post_install $1
+}