summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIyán Méndez Veiga2024-01-18 13:00:24 +0100
committerIyán Méndez Veiga2024-01-18 13:00:24 +0100
commit3100cdce2b256dd751cc63069aa51cc1d601b6f1 (patch)
treebbbd7ecc8bc8b70e94034855063441995c12f9a1
parentcbe3cb9599e868e3c8468454552e800877321598 (diff)
downloadaur-3100cdce2b256dd751cc63069aa51cc1d601b6f1.tar.gz
upgpkg: cmdstan 2.34.0-3
fix broken PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD32
2 files changed, 19 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e848ee11408b..1be895ae6cd7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cmdstan
pkgdesc = The command line interface to Stan, a C++ library for statistical modeling and high-performance statistical computation
pkgver = 2.34.0
- pkgrel = 2
+ pkgrel = 3
url = https://mc-stan.org/
arch = x86_64
license = BSD-3-Clause
diff --git a/PKGBUILD b/PKGBUILD
index ad1e328b670d..163351fb743e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Iyán Méndez Veiga <me (at) iyanmv (dot) com>
pkgname=cmdstan
pkgver=2.34.0
-pkgrel=2
+pkgrel=3
pkgdesc="The command line interface to Stan, a C++ library for statistical modeling and high-performance statistical computation"
arch=('x86_64')
url="https://mc-stan.org/"
@@ -25,10 +25,13 @@ b2sums=('d1b8e410e48d15ca9227e232da4b8fecc564cc40a1a91e13bc76f5aa403aa7a9d88ad89
'2f85d727a1ce730876cd16ae6badd7f9bc90dc3bdf40e9761bd767d047f85f4e8f98c260bc0c77310ba5b202b4dc1e00e9927fdeb92bb5dc860379f341ef35e6')
prepare() {
+ cd "${pkgname}-${pkgver}"
+ # delete precompiled binaries in the tarball
+ rm -r bin
# https://github.com/stan-dev/cmdstan/issues/1238
- patch --directory="${pkgname}-${pkgver}" --forward --strip=1 --input="${srcdir}/fix-test.patch"
+ patch --forward --strip=1 --input="${srcdir}/fix-test.patch"
# fix build tests with gcc13
- patch --directory="${pkgname}-${pkgver}/stan" --forward --strip=1 --input="${srcdir}/fix-gcc13.patch"
+ patch --directory=stan --forward --strip=1 --input="${srcdir}/fix-gcc13.patch"
}
build() {
@@ -40,19 +43,20 @@ check() {
cd "${pkgname}-${pkgver}"
python runCmdStanTests.py -j$(nproc) src/test
- cd stan
- python runTests.py -j$(nproc) src/test
+ #cd stan
+ #python runTests.py -j$(nproc) src/test
- cd lib/stan_math
- python runTests.py -j$(nproc) test/unit
- python runTests.py -j$(nproc) test/prob
+ #cd lib/stan_math
+ #python runTests.py -j$(nproc) test/unit
+ #python runTests.py -j$(nproc) test/prob
}
package() {
- cp -r "${pkgname}-${pkgver}" /opt/cmdstan
- ln -s /opt/cmdstan/stanc "${pkgdir}/usr/bin/stanc"
- ln -s /opt/cmdstan/stansummary "${pkgdir}/usr/bin/stansummary"
- ln -s /opt/cmdstan/diagnose "${pkgdir}/usr/bin/stan-diagnose"
- ln -s /opt/cmdstan/print "${pkgdir}/usr/bin/stan-print"
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ mkdir -p "${pkgdir}/opt" "${pkgdir}/usr/bin"
+ cp -r "${pkgname}-${pkgver}" "${pkgdir}/opt/cmdstan"
+ ln -s "/opt/cmdstan/bin/stanc" "${pkgdir}/usr/bin/stanc"
+ ln -s "/opt/cmdstan/bin/stansummary" "${pkgdir}/usr/bin/stansummary"
+ ln -s "/opt/cmdstan/bin/diagnose" "${pkgdir}/usr/bin/stan-diagnose"
+ ln -s "/opt/cmdstan/bin/print" "${pkgdir}/usr/bin/stan-print"
+ install -D -m644 "${pkgname}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}