summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhpmachining2020-07-03 20:04:41 -0400
committerhpmachining2020-07-03 20:04:41 -0400
commit58e2ea638a0f485009b9e432562afd6943f71bb9 (patch)
tree7a37c336319b44c95ba17e872e8f179940ae84b0
downloadaur-58e2ea638a0f485009b9e432562afd6943f71bb9.tar.gz
Initial commit.
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD34
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5ddaceec298
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cmoc
+ pkgdesc = 6809-generating cross-compiler for a subset of the C language.
+ pkgver = 0.1.67
+ pkgrel = 1
+ url = http://perso.b2b2c.ca/~sarrazip/dev/cmoc.html
+ arch = x86_64
+ license = GPL3
+ makedepends = discount
+ depends = perl
+ depends = lwtools
+ source = http://perso.b2b2c.ca/~sarrazip/dev/cmoc-0.1.67.tar.gz
+ sha256sums = d27f41f93315a74d7c8b07ec5feff18479992691e412659649f1d0f9050057cd
+
+pkgname = cmoc
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7735b4612827
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+!*.patch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3aa9d866f18
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Paul Hentschel <aur at hpminc dot com>
+
+pkgname=cmoc
+pkgver=0.1.67
+pkgrel=1
+pkgdesc="6809-generating cross-compiler for a subset of the C language."
+arch=('x86_64')
+url="http://perso.b2b2c.ca/~sarrazip/dev/cmoc.html"
+license=('GPL3')
+depends=('perl' 'lwtools')
+makedepends=('discount')
+source=("http://perso.b2b2c.ca/~sarrazip/dev/$pkgname-$pkgver.tar.gz")
+sha256sums=('d27f41f93315a74d7c8b07ec5feff18479992691e412659649f1d0f9050057cd')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make && make html
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check -j1
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+
+ # Install html documentation
+ install -m644 doc/cmoc-{implementation,manual,vectrex}.html "$pkgdir/usr/share/doc/$pkgname"
+}
+
+# vim:set ts=2 sw=2 et: