summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConrad Hoffmann2022-03-09 16:25:34 +0100
committerConrad Hoffmann2022-03-09 16:28:55 +0100
commit9d1dbbe7a01053984fb911a3bb0f5958db0a0c85 (patch)
tree10e796e9494aef70df2aea6ac47dd11c42dab3f3
downloadaur-9d1dbbe7a01053984fb911a3bb0f5958db0a0c85.tar.gz
Initial release
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..74af50e298b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = cmos-git
+ pkgdesc = Small markdown renderer based on CommonMark libcmark
+ pkgver = v1.0.r1.g1a633e0
+ pkgrel = 1
+ url = https://sr.ht/~bitfehler/cmos
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ depends = libunistring
+ depends = cmark
+ depends = source-highlight
+ provides = cmos
+ conflicts = cmos
+ source = cmos-git::git+https://git.sr.ht/~bitfehler/cmos
+ sha512sums = SKIP
+
+pkgname = cmos-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51013a0ab495
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=cmos-git
+pkgver=v1.0.r1.g1a633e0
+pkgrel=1
+pkgdesc='Small markdown renderer based on CommonMark libcmark'
+arch=(x86_64)
+url='https://sr.ht/~bitfehler/cmos'
+license=(MIT)
+depends=(
+ 'libunistring'
+ 'cmark'
+ 'source-highlight'
+)
+makedepends=(git meson ninja)
+provides=('cmos')
+conflicts=('cmos')
+
+source=("${pkgname}::git+https://git.sr.ht/~bitfehler/cmos")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ mkdir -p build
+ arch-meson build "$pkgname"
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}
+
+# vim: ts=2 sw=2 et