summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdoardo Morassutto2018-06-13 09:16:41 +0200
committerEdoardo Morassutto2018-06-13 09:16:41 +0200
commitaf05e7dab1ba48665b4f32877a6ed6678e96f793 (patch)
tree51fa692279de55a7804a7113dbe33763fefa6b48
downloadaur-af05e7dab1ba48665b4f32877a6ed6678e96f793.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..236250454152
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = cmsbooklet-git
+ pkgdesc = cmsbooklet is a tool meant to facilitate the typesetting of olympic problems. It is designed to work well with CMS, the Contest Management System.
+ pkgver = r75.4a4af05
+ pkgrel = 1
+ url = https://github.com/algorithm-ninja/cmsbooklet
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = AGPL3
+ makedepends = python2-setuptools
+ depends = python2
+ depends = python2-jinja
+ depends = python2-pyaml
+ source = git+https://github.com/algorithm-ninja/cmsbooklet.git
+ sha384sums = SKIP
+
+pkgname = cmsbooklet-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..598603e94a9b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+cmsbooklet/
+pkg/
+src/
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e40e7e2e6122
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Edoardo Morassutto <edoardo.morassutto@gmail.com>
+
+pkgname=cmsbooklet-git
+pkgver=r75.4a4af05
+pkgrel=1
+pkgdesc="cmsbooklet is a tool meant to facilitate the typesetting of olympic problems. It is designed to work well with CMS, the Contest Management System."
+arch=('any')
+url="https://github.com/algorithm-ninja/cmsbooklet"
+license=('AGPL3')
+depends=('python2' 'python2-jinja' 'python2-pyaml')
+makedepends=('python2-setuptools')
+source=("git+https://github.com/algorithm-ninja/cmsbooklet.git")
+sha384sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/cmsbooklet"
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/cmsbooklet"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+