summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRenato Florentino Garcia2016-05-19 19:21:12 -0300
committerRenato Florentino Garcia2016-05-19 19:21:12 -0300
commit4e888b63533f45294414e423a1d98bf899b4dd5c (patch)
treea4a4993a315fd9a71a7350f4b5d4823275213981
downloadaur-cmvs.tar.gz
Version 1.2-1
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD30
-rw-r--r--cmvs.patch86
3 files changed, 139 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c0f9a6daaac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Thu May 19 22:20:30 UTC 2016
+pkgbase = cmvs
+ pkgdesc = Clustering Views for Multi-view Stereo.
+ pkgver = 1.2
+ pkgrel = 1
+ url = http://www.di.ens.fr/cmvs/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = lapacke
+ depends = graclus
+ depends = gsl
+ depends = libxext
+ depends = libjpeg-turbo
+ depends = atlas-lapack
+ source = http://www.di.ens.fr/cmvs/cmvs-fix2.tar.gz
+ source = cmvs.patch
+ md5sums = 16a6c614a081c276aa24f0986b989ba0
+ md5sums = 4af833320117d109b0f0dc212a151814
+
+pkgname = cmvs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81c63b481cbe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Renato Garcia <fgarcia.renato@gmail.com>
+
+pkgname=cmvs
+pkgver=1.2
+pkgrel=1
+pkgdesc="Clustering Views for Multi-view Stereo."
+arch=('i686' 'x86_64')
+url="http://www.di.ens.fr/cmvs/"
+license=('GPL')
+depends=('graclus' 'gsl' 'libxext' 'libjpeg-turbo' 'atlas-lapack')
+makedepends=('lapacke')
+source=("http://www.di.ens.fr/cmvs/cmvs-fix2.tar.gz"
+ "cmvs.patch")
+md5sums=('16a6c614a081c276aa24f0986b989ba0'
+ '4af833320117d109b0f0dc212a151814')
+
+prepare() {
+ cd "${pkgname}"
+ patch -Np1 -i "${srcdir}/cmvs.patch"
+}
+
+build() {
+ cd "${pkgname}/program/main/"
+ make
+}
+
+package() {
+ cd "${pkgname}/program/main/"
+ install -D -t "${pkgdir}/usr/bin" pmvs2 cmvs genOption
+}
diff --git a/cmvs.patch b/cmvs.patch
new file mode 100644
index 000000000000..fda3bc5c3d64
--- /dev/null
+++ b/cmvs.patch
@@ -0,0 +1,86 @@
+diff -ruN cmvs/program/base/cmvs/bundle.cc cmvs_patched/program/base/cmvs/bundle.cc
+--- cmvs/program/base/cmvs/bundle.cc 2011-03-27 19:46:01.000000000 -0300
++++ cmvs_patched/program/base/cmvs/bundle.cc 2016-05-18 13:01:04.927852729 -0300
+@@ -1,5 +1,6 @@
+ #include <fstream>
+ #include <iterator>
++#include <numeric>
+
+ #ifdef _OPENMP
+ #include <omp.h>
+@@ -1131,7 +1132,7 @@
+ for (int i = 0; i < (int)m_timages.size(); ++i)
+ sort(m_timages[i].begin(), m_timages[i].end());
+
+- return accumulate(addnum.begin(), addnum.end(), 0);
++ return std::accumulate(addnum.begin(), addnum.end(), 0);
+ }
+
+ int Cbundle::totalNum(void) const{
+diff -ruN cmvs/program/base/numeric/mylapack.cc cmvs_patched/program/base/numeric/mylapack.cc
+--- cmvs/program/base/numeric/mylapack.cc 2010-04-03 19:11:17.000000000 -0300
++++ cmvs_patched/program/base/numeric/mylapack.cc 2016-05-18 01:23:52.859993590 -0300
+@@ -3,9 +3,11 @@
+ #include <iostream>
+
+ extern "C" {
+-#include <clapack/f2c.h>
+-#include <clapack/clapack.h>
++//#include <clapack/f2c.h>
++//#include <clapack/clapack.h>
++#include <lapacke.h>
+ };
++#define integer int
+
+ using namespace std;
+
+diff -ruN cmvs/program/base/numeric/mylapack.h cmvs_patched/program/base/numeric/mylapack.h
+--- cmvs/program/base/numeric/mylapack.h 2010-04-03 19:11:17.000000000 -0300
++++ cmvs_patched/program/base/numeric/mylapack.h 2016-05-18 01:26:18.144433627 -0300
+@@ -28,11 +28,11 @@
+
+ static void lls(std::vector<float>& A,
+ std::vector<float>& b,
+- long int width, long int height);
++ int width, int height);
+
+ static void lls(std::vector<double>& A,
+ std::vector<double>& b,
+- long int width, long int height);
++ int width, int height);
+
+ // SVD
+ // A = U Sigma V^T
+diff -ruN cmvs/program/base/stann/dpoint.hpp cmvs_patched/program/base/stann/dpoint.hpp
+--- cmvs/program/base/stann/dpoint.hpp 2010-04-03 20:15:25.000000000 -0300
++++ cmvs_patched/program/base/stann/dpoint.hpp 2016-05-18 12:37:39.393331452 -0300
+@@ -489,7 +489,7 @@
+ if(!(is >> p[i])){
+ if(!is.eof()){
+ std::cerr << "Error Reading Point:"
+- << is << std::endl;
++ << "is" << std::endl;
+ exit(1);
+ }
+ }
+diff -ruN cmvs/program/main/Makefile cmvs_patched/program/main/Makefile
+--- cmvs/program/main/Makefile 2010-04-10 00:27:30.000000000 -0300
++++ cmvs_patched/program/main/Makefile 2016-05-19 11:03:09.154747997 -0300
+@@ -7,13 +7,13 @@
+ ######################################################################
+ CXX = g++
+
+-Your INCLUDE path (e.g., -I/usr/include)
++#Your INCLUDE path (e.g., -I/usr/include)
+ YOUR_INCLUDE_PATH =
+
+-Your metis directory (contains header files under graclus1.2/metisLib/)
+-YOUR_INCLUDE_METIS_PATH =
++#Your metis directory (contains header files under graclus1.2/metisLib/)
++YOUR_INCLUDE_METIS_PATH =-I/usr/include/metis
+
+-Your LDLIBRARY path (e.g., -L/usr/lib)
++#Your LDLIBRARY path (e.g., -L/usr/lib)
+ YOUR_LDLIB_PATH =
+
+ ######################################################################