summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Brooks2016-05-01 00:34:51 -0400
committerKyle Brooks2016-05-01 00:34:51 -0400
commit196761e4ee576927f6a2197f817e8624bc8952c5 (patch)
tree72acabd10652a2e7814ac4d5109441fc29768489
downloadaur-196761e4ee576927f6a2197f817e8624bc8952c5.tar.gz
Initial commit.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98196e3c9414
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = cmvs-pmvs-git
+ pkgdesc = Takes output from structure from motion frameworks (SfM) and produces dense 3D reconstruction from the camera poses and imagery.
+ pkgver = r20.a5c2bc1
+ pkgrel = 2
+ url = https://github.com/pmoulon/CMVS-PMVS
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ makedepends = boost
+ depends = libjpeg
+ depends = boost-libs
+ source = git+https://github.com/pmoulon/CMVS-PMVS.git
+ md5sums = SKIP
+
+pkgname = cmvs-pmvs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a755d51b7ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Kyle Brooks <brookskd@gmail.com>
+pkgname=cmvs-pmvs-git
+pkgver=r20.a5c2bc1
+pkgrel=2
+pkgdesc='Takes output from structure from motion frameworks (SfM) and produces dense 3D reconstruction from the camera poses and imagery.'
+arch=('i686' 'x86_64')
+url='https://github.com/pmoulon/CMVS-PMVS'
+license=('GPL')
+depends=('libjpeg' 'boost-libs')
+makedepends=('git' 'cmake' 'boost')
+_gitname='CMVS-PMVS'
+source=("git+https://github.com/pmoulon/${_gitname}.git"
+ )
+md5sums=('SKIP'
+ )
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}"
+ mkdir -p cmvs-pmvs_build
+ cd cmvs-pmvs_build
+ cmake -DCMAKE_BUILD_TYPE=RELEASE "../${_gitname}/program"
+ make
+}
+
+package() {
+ cd "${srcdir}/cmvs-pmvs_build"
+ install -Dm755 main/cmvs "${pkgdir}/usr/bin/cmvs"
+ install -Dm755 main/genOption "${pkgdir}/usr/bin/genOption"
+ install -Dm755 main/pmvs2 "${pkgdir}/usr/bin/pmvs2"
+}
+
+# vim:set ts=2 sw=2 et: