summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2020-12-24 11:06:37 +0800
committerYour Name2020-12-24 11:06:37 +0800
commit3dbeb8034cdf1d4d490a42cd1faac84d1551cb7d (patch)
treea8a6786aa9b5a21d763ca95484736c766484438e
downloadaur-3dbeb8034cdf1d4d490a42cd1faac84d1551cb7d.tar.gz
Pack cn.feishu.deepin
-rw-r--r--.SRCINFO21
-rwxr-xr-xPKGBUILD37
-rw-r--r--feishu.install10
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d875e4314ed7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = cn.feishu.deepin
+ pkgdesc = Fei Shu (飞书) Client on Deepin Wine
+ pkgver = 3.32.3
+ pkgrel = 2
+ url = https://www.feishu.cn/
+ install = feishu.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = tar
+ depends = deepin-wine5-stable>=5.0.0.17
+ depends = deepin-wine-helper>=5.1.15
+ depends = p7zip
+ depends = xdg-utils
+ depends = hicolor-icon-theme
+ optdepends = ttf-ms-fonts: Microsoft Core fonts
+ optdepends = noto-fonts-cjk: Google Noto CJK fonts
+ source = https://cdn-package-store6.deepin.com/appstore/pool/appstore/c/cn.feishu.deepin/cn.feishu.deepin_3.32.3deepin2_i386.deb
+ sha512sums = 8c68f24d8cc91e20cab625115d9cf2a62ef320fcfc76e642949fc4f3def2edb0298fca6590b9ec359b743cc374c122d87078add9c6aa3671311469f9e0950b19
+
+pkgname = cn.feishu.deepin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..81204601060e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributer: Sam L. Yes <samlukeyes123@gmail.com>
+pkgname=cn.feishu.deepin
+pkgver=3.32.3
+pkgrel=2
+epoch=
+pkgdesc="Fei Shu (飞书) Client on Deepin Wine"
+arch=('i686' 'x86_64')
+url="https://www.feishu.cn/"
+license=('unknown')
+groups=()
+depends=('deepin-wine5-stable>=5.0.0.17' 'deepin-wine-helper>=5.1.15' 'p7zip' 'xdg-utils' 'hicolor-icon-theme')
+makedepends=('tar')
+checkdepends=()
+optdepends=('ttf-ms-fonts: Microsoft Core fonts'
+ 'noto-fonts-cjk: Google Noto CJK fonts')
+provides=()
+replaces=()
+backup=()
+options=()
+install=feishu.install
+changelog=
+source=("https://cdn-package-store6.deepin.com/appstore/pool/appstore/c/${pkgname}/${pkgname}_${pkgver}deepin${pkgrel}_i386.deb")
+sha512sums=('8c68f24d8cc91e20cab625115d9cf2a62ef320fcfc76e642949fc4f3def2edb0298fca6590b9ec359b743cc374c122d87078add9c6aa3671311469f9e0950b19')
+validpgpkeys=()
+
+package() {
+ cd ${pkgdir}
+ tar xpvf ${srcdir}/data.tar.xz --xattrs-include='*' --numeric-owner
+ install -d usr/share
+ mv opt/apps/${pkgname}/entries/* usr/share
+ rmdir opt/apps/${pkgname}/entries
+ cd opt/apps/${pkgname}/files
+ sed -i "/extract_archive \"/d" run.sh
+ sed -i "s|\$HOME/.deepinwine/deepin-wine-helper|/opt/deepinwine/tools|" run.sh
+ sed -i "s|\$HOME/.deepinwine|/usr/lib|" run.sh
+ rm wine_archive.* helper_archive.*
+}
diff --git a/feishu.install b/feishu.install
new file mode 100644
index 000000000000..4573918eb410
--- /dev/null
+++ b/feishu.install
@@ -0,0 +1,10 @@
+post_upgrade() {
+ echo
+ echo "Remove ~/.deepinwine/Deepin-Feishu to generate a new bottle."
+ echo
+}
+
+post_remove() {
+ echo "Deleting existing Feishu bottles..."
+ find /home -maxdepth 2 -name ".deepinwine" -exec rm -rf \{\}/Deepin-Feishu/ \;
+} \ No newline at end of file