summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorgeRaven2021-05-31 17:03:07 +0100
committerGeorgeRaven2021-05-31 17:03:07 +0100
commit950d3d0905d2bf3ada06a3d1958c18de92860172 (patch)
tree4e107963d6b735b3b45d057156382ac50cb863e3
parentb82142ee6f77f7d5247cfb46a0254c6157576afb (diff)
downloadaur-950d3d0905d2bf3ada06a3d1958c18de92860172.tar.gz
Added alternate install location
The default kubelet package references /usr/lib/cni so added a second set of bins at this location. Could in future symlink if this works properly which I will test next.
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f7a8d843dab..5c8f0ddfede6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,7 +27,11 @@ source+=(${pkgname}-${pkgver}::"https://github.com/containernetworking/plugins/r
package() {
cd "${srcdir}"
+ # get rid of unwanted link
unlink "${pkgname}-${pkgver}"
- mkdir -p "${pkgdir}/opt/cni/bin"
+ # install to default location
+ mkdir -p "${pkgdir}/opt/cni/bin" "${pkgdir}/usr/lib/cni"
install -Dm755 "${srcdir}/"* "${pkgdir}/opt/cni/bin/."
+ # also deposit bins in alternate possible location
+ install -Dm755 "${srcdir}/"* "${pkgdir}/usr/lib/cni"
}