summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2018-02-05 01:04:23 -0500
committerChris Severance2018-02-05 01:04:23 -0500
commited2e3af2ea534d0c9c0d379e5507791c8b9fea8d (patch)
treedd61d920c622242e0a5d89802aaa29ee5cfbefb0
downloadaur-ed2e3af2ea534d0c9c0d379e5507791c8b9fea8d.tar.gz
Initial Import
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD36
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46432a44b4a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+# Generated by mksrcinfo v8
+# Mon Feb 5 06:02:52 UTC 2018
+pkgbase = cnijfilter-ip1800-bin
+ pkgdesc = Canon IJ Printer Driver for Pixma IP1800 multifunction
+ pkgver = 2.70
+ pkgrel = 1
+ url = http://support-au.canon.com.au/contents/AU/EN/0900718516.html
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = LGPL2
+ license = custom
+ depends = cnijfilter-common
+ depends = libglade
+ source = http://files.canon-europe.com/files/soft27213/Software/27213.tgz
+ md5sums = 9a5e8bc016ed78551a7f5d197212e857
+ sha256sums = 553bec45915b8727633ecc780259777817a00d47e1f90f30048b814884403e40
+ depends_i686 = glibc
+ depends_i686 = popt
+ depends_i686 = libpng12
+ depends_i686 = libtiff
+ depends_i686 = xz
+ depends_i686 = libjpeg-turbo
+ depends_i686 = zlib
+ depends_i686 = libtiff3
+ depends_i686 = gtk
+ depends_i686 = libxml
+ depends_x86_64 = lib32-glibc
+ depends_x86_64 = lib32-popt
+ depends_x86_64 = lib32-libpng12
+ depends_x86_64 = lib32-libtiff
+ depends_x86_64 = lib32-xz
+ depends_x86_64 = lib32-libjpeg-turbo
+ depends_x86_64 = lib32-zlib
+ depends_x86_64 = lib32-libtiff3
+ depends_x86_64 = lib32-gtk
+ depends_x86_64 = lib32-libxml
+
+pkgname = cnijfilter-ip1800-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d726c8634365
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: Eric Le Bras <eric.lebras@gmail.com>
+
+set -u
+pkgname='cnijfilter-ip1800-bin'
+pkgver='2.70'
+pkgrel='1'
+pkgdesc='Canon IJ Printer Driver for Pixma IP1800 multifunction'
+arch=('i686' 'x86_64')
+url='http://support-au.canon.com.au/contents/AU/EN/0900718516.html'
+license=('GPL2' 'LGPL2' 'custom')
+depends=('cnijfilter-common' 'libglade') # 'cnijfilter-common270'
+depends_i686=('glibc' 'popt' "libpng12" 'libtiff' 'xz' 'libjpeg-turbo' 'zlib' 'libtiff3' 'gtk' 'libxml')
+depends_x86_64=("${depends_i686[@]/#/lib32-}")
+source=("http://files.canon-europe.com/files/soft27213/Software/27213.tgz")
+md5sums=('9a5e8bc016ed78551a7f5d197212e857')
+sha256sums=('553bec45915b8727633ecc780259777817a00d47e1f90f30048b814884403e40')
+
+prepare() {
+ set -u
+ cd ${srcdir}
+ bsdtar -xvf '27213.tgz'
+ set +u
+}
+
+package() {
+ set -u
+ cd "${pkgdir}"
+ bsdtar -xf "${srcdir}/cnijfilter-ip1800series-2.70-1.i386.rpm"
+ mv 'usr/local/bin' 'usr/'
+ mv 'usr/local/share'/* 'usr/share/'
+ rmdir 'usr/local/share' 'usr/local'
+ #mv 'usr/lib' 'usr/lib32' # hardcoded paths
+ set +u
+}
+set +u