summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author公子希夷2021-03-30 12:58:08 +0800
committer公子希夷2021-03-30 12:58:08 +0800
commit3d2d12eba6a4e65416ca4c01d81800c862fb44b9 (patch)
treee29e57f286279c2555c5d59f9b94181bac98227f
downloadaur-3d2d12eba6a4e65416ca4c01d81800c862fb44b9.tar.gz
Example
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD18
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88adcd4a625a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = cnkiexpress
+ pkgdesc = cnki for arch
+ pkgver = 0.0.10
+ pkgrel = 1
+ url = http://cajviewer.cnki.net/download.html
+ arch = i686
+ arch = x86_64
+ groups = cnkiexpress
+ license = GPL
+ makedepends = yay
+ makedepends = debtap
+ makedepends = wget
+ depends = at-spi2-core
+ depends = desktop-file-utils
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = libappindicator-gtk3
+ depends = libnotify
+ depends = libsecret
+ depends = libxss
+ depends = libxtst
+ depends = nss
+ depends = util-linux-libs
+ depends = xdg-utils
+ source = https://download.cnki.net/cnkiexpress/cnkiexpress_0.0.10_amd64.deb
+ sha512sums = SKIP
+
+pkgname = cnkiexpress
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..744abf8a5568
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: xylzq
+pkgname=cnkiexpress
+pkgver=0.0.10
+pkgrel=1
+pkgdesc="cnki for arch"
+arch=('i686' 'x86_64')
+url="http://cajviewer.cnki.net/download.html"
+license=('GPL')
+groups=(cnkiexpress)
+depends=(at-spi2-core desktop-file-utils gtk3 hicolor-icon-theme libappindicator-gtk3 libnotify libsecret libxss libxtst nss util-linux-libs xdg-utils)
+makedepends=(yay debtap wget)
+source=("https://download.cnki.net/"$pkgname"/"$pkgname"_"$pkgver"_amd64.deb")
+sha512sums=("SKIP")
+package() {
+ sudo debtap -u
+ sudo debtap $pkgname_$pkgver_amd64.deb
+ sudo pacman -U $pkgname_$pkgver.pkg.tar.zst
+}