summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2023-05-27 15:47:58 -0400
committeréclairevoyant2023-05-27 15:47:58 -0400
commitc3de4a51b72583bbb3a62a46cebc007830416a51 (patch)
tree3fe986acdb3329235e5ef642a17de54e5818ed5a
parent4ca56be87fa971d616991919a05ca2f89915e119 (diff)
downloadaur-cnoor-git.tar.gz
fix url, deps, source, quoting; respect compilation flags; remove garbage files from AUR repo
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD74
-rw-r--r--cnoor-git.install11
-rw-r--r--config.h21
5 files changed, 37 insertions, 104 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59b5a824b6e6..1fe5e662dbb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,17 @@
pkgbase = cnoor-git
- pkgdesc = A simple framebuffer holy Quran viewer.
- pkgver = r93.458780d
+ pkgdesc = Simple framebuffer holy Quran viewer
+ pkgver = r94.2b58c5a
pkgrel = 1
- url = http://litcave.rudi.ir/
- install = cnoor-git.install
+ url = https://litcave.rudi.ir/
arch = i686
arch = x86_64
- license = GPL
+ license = unknown
makedepends = git
+ makedepends = mold
+ depends = pango
optdepends = ttf-sil-scheherazade: quran font
optdepends = ttf-dejavu: reader font
- source = cnoor-git::git+git://repo.or.cz/cnoor.git
- source = cnoor.1
- source = config.h
- source = http://tanzil.net/trans/en.ahmedali
- md5sums = SKIP
- md5sums = c5e914abff7843191998a5a3da0c386d
- md5sums = ab0e8455b71c4042c8acbdbafba5d8e0
- md5sums = 4440b64e31448eee1e65f3ad09439dac
- sha1sums = SKIP
- sha1sums = 8a232ff84fe36112e0d58aa06f6978f63c81c1dc
- sha1sums = 3ae09c097c17155be2ac80af24314f685bdd275a
- sha1sums = 039ef775054904e89278a6d5f27ae04d80d41ffa
- sha256sums = SKIP
- sha256sums = d87c5c5c4585f09f3af7a39e8ebb75f7b9a673e95966f56249b17cfcba1d6bba
- sha256sums = 624cd5c1a4202695682ecccc338273d74d51029179319bc28ddbd7e9f76e4987
- sha256sums = 4fdc3e02ab16c6f6d841416c4b86cc1ad950a2c0436f5c92637db67c813ed62d
+ source = git://repo.or.cz/cnoor.git
+ b2sums = SKIP
pkgname = cnoor-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..94a25912dc9e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/*
+!/.gitignore
+!/.SRCINFO
+!/PKGBUILD
+!/cnoor.1
diff --git a/PKGBUILD b/PKGBUILD
index 8c0248e9c710..08114fa345c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,66 +1,40 @@
+# Maintainer: éclairevoyant
# Contributor: Sara <sara at archlinux dot us>
-# Maintainer: aksr <aksr at t-com dot me>
-pkgname=cnoor-git
-pkgver=r93.458780d
+# Contributor: aksr <aksr at t-com dot me>
+
+_pkgname=cnoor
+pkgname="$_pkgname-git"
+pkgver=r94.2b58c5a
pkgrel=1
-epoch=
-pkgdesc="A simple framebuffer holy Quran viewer."
-arch=('i686' 'x86_64')
-url="http://litcave.rudi.ir/"
-license=('GPL')
-groups=()
-depends=('')
-makedepends=('git')
-optdepends=()
+pkgdesc="Simple framebuffer holy Quran viewer"
+arch=(i686 x86_64)
+url="https://litcave.rudi.ir/"
+license=(unknown)
+depends=(pango)
+makedepends=(git mold)
optdepends=('ttf-sil-scheherazade: quran font'
'ttf-dejavu: reader font')
-checkdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-changelog=
-install=$pkgname.install
-source=("$pkgname::git+git://repo.or.cz/cnoor.git"
- 'cnoor.1'
- 'config.h'
- 'http://tanzil.net/trans/en.ahmedali')
-noextract=()
-md5sums=('SKIP'
- 'c5e914abff7843191998a5a3da0c386d'
- 'ab0e8455b71c4042c8acbdbafba5d8e0'
- '4440b64e31448eee1e65f3ad09439dac')
-sha1sums=('SKIP'
- '8a232ff84fe36112e0d58aa06f6978f63c81c1dc'
- '3ae09c097c17155be2ac80af24314f685bdd275a'
- '039ef775054904e89278a6d5f27ae04d80d41ffa')
-sha256sums=('SKIP'
- 'd87c5c5c4585f09f3af7a39e8ebb75f7b9a673e95966f56249b17cfcba1d6bba'
- '624cd5c1a4202695682ecccc338273d74d51029179319bc28ddbd7e9f76e4987'
- '4fdc3e02ab16c6f6d841416c4b86cc1ad950a2c0436f5c92637db67c813ed62d')
+source=("git://repo.or.cz/$_pkgname.git"
+ $_pkgname.1)
+b2sums=('SKIP'
+ 'fc621c7109234fca67915804a7f6e9b408f4d8e643cb021fd3b05a72f37bb8de9fa2df34f866b09f8a2d1a56c9e7fc8eada65753a30c217db0150468208c4b00')
pkgver() {
- cd $srcdir/$pkgname
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd $srcdir/$pkgname
- cp $srcdir/config.h config.h
- sed -i "10s|user|$HOME/.quran/quran-simple.txt|" config.h
+ sed -i '/FLAGS =/ s/=/+=/' $_pkgname/Makefile
}
build() {
- cd $srcdir/$pkgname
- make all
+ # does not link correctly with as-needed and ld
+ mold -run make -C $_pkgname all
}
package() {
- cd $srcdir/$pkgname
- install -Dm755 cnoor $pkgdir/usr/bin/cnoor
- install -Dm755 README $pkgdir/usr/share/doc/${pkgname//-git/}/README
- install -Dm644 ../cnoor.1 $pkgdir/usr/share/man/man1/cnoor.1
- install -Dm644 ../en.ahmedali $pkgdir/usr/share/doc/cnoor/en.ahmedali
+ cd $_pkgname
+ install -Dm755 $_pkgname -t "$pkgdir/usr/bin/"
+ install -Dm755 README -t "$pkgdir/usr/share/doc/$_pkgname/"
}
-
diff --git a/cnoor-git.install b/cnoor-git.install
deleted file mode 100644
index f6c56a1f4e14..000000000000
--- a/cnoor-git.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- echo "==> You have to download Arabic Quran text file: "
- echo " \"http://tanzil.info/download\" "
- echo " By default, its path is \"\$HOME/.quran/quran-simple.txt\". "
- echo "==> Note: The path to the Arabic Quran text file is absolute. "
- echo "==> If you want to change the Quran text file location and/or other settings: "
- echo " * Edit config.h "
- echo " * $ updpkgsums "
- echo " * Rebuild and install the package. "
-}
-
diff --git a/config.h b/config.h
deleted file mode 100644
index 140054b548d9..000000000000
--- a/config.h
+++ /dev/null
@@ -1,21 +0,0 @@
-/* cnoor config file */
-
-/* framebuffer depth */
-typedef unsigned int fbval_t;
-
-/* optimized version of fb_val() */
-#define FB_VAL(r, g, b) fb_val((r), (g), (b))
-
-/* you can get it from http://tanzil.info/download */
-#define QURAN_PATH "user"
-/* it should be a utf-8 file with one aya per line or NULL */
-#define TRANS_PATH "/usr/share/doc/cnoor/en.ahmedali"
-
-/* fonts and colors */
-#define COLOR_FG 0x000000
-#define COLOR_BG 0xd5ddff
-#define FONT_QURAN "scheherazade 17"
-#define FONT_TRANS "DejaVu Sans 8"
-#define FONT_NUM "DejaVu Sans Mono 7"
-#define FONT_JUZ "DejaVu Sans Mono 7"
-#define FONT_SAJDA "DejaVu Sans Mono 7"